Download

[problem] maya and animation rigging toolkit

Hello,

I got a problem with animation and rigging toolkit.
When i want to build my control rig, maya told me that file may already exist and be marked as read only.
After some attempt to solve the problem by myself it’s look like nothing work.

File doesn’t exist.
Directory marked at read only and can’t change that.

How could i fixed it?

Cordially Axel.

Hey Axel,

I’ll try to see if I can reproduce this on my side. I personally haven’t had this error but, I’ll see if I can find a reason as to why it would do this.

Thanks for your patience,

Jerry

Thx jerry :slight_smile:

do you get only this error, and there is no button like “skip”, “browse” or “cancel” ?
i had that error before to understand that maya tried to load the mannequin_export.fbx file from a wrong path.
So if there any browse button use it and to look in there : X:\Unreal Engine\4.0\Engine\Extras\Maya_AnimationRiggingTools\MayaTools\General\ART\Projects\Sample\ExportFiles
(replace x by your own hard drive partition where unreal is installed.)

Nop :

http://imageshack.com/a/img534/1135/fu2b.png

I have the same problem

Hey there!

I assume those having this issue are using a maya version other than 2014? If so, I think I may have a fix for you. I accidentally checked in a compiled version of one the scripts, and that may be giving you issues.
Try using the source version here:

Just paste in MayaTools/General/Scripts and see if that solves your problems.

Thanks!

Hi Jeremy.

First off…thanks for writing these tools and helping to get people up and running with them.

I am running on Maya 2013 and am having the same issue. I tried dropping in the script you posted above but it didn’t seem to work. I still get the same publish error. Are most people not having this problem? Thanks for the support.

~Sean

Hey there.

Just wondering if anyone figured out what is causing the error yet? Should I re-install the whole script?

Thanks!

Hello, I have a some bugs with maya rig tool aswell…

0th. - Wrong path by loading mannequin d/:build/unreal4~ and when I use browse and use the real path, it does not save though I check it to save… and the next time I try to open mannequin it gives wrong path again…

another problem is with exporting fbx file with some character created with rig… when I use export selected from file list it gives me 2 warnings

1st - complex animation baked. 47 attributes had complex animation. Complex animation was exported as baked curves. (4747 evaluations done)

2nd. - The fbx plug-in does not support assets created by advanced asset menu. The following container(s) will be ignored: irvelnaujas:JointMover. (at the end I get a fbx file that can’t be used… even after importing back I get only some foot wireframes or so…) and it does not load in ue4…

3rd. - Error: ValueError: file C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_poseEditor.py line 944: could not convert string to float # when I try to use hand poses.

At the end rigging tool becomes pretty useless… ;(

Would be glad to know if these errors could be fixed. Thx in advance.

Hi everyone,

Jeremy Ernst released an announcement about the known animation/rigging tools issues here: Animation and Rigging Tools: FAQ, Known Issues and Feature Roadmap - Animation - Unreal Engine Forums, perhaps something is mentioned there that may help you? Thank you and have a great day!