[PROBLEM] Maya 2012 Import SkeletalMesh


I am attempting to import a Skeletalmesh with animations to UE4 from Maya 2012 using FBX 2013.3 (I can’t find any later versions).

I am easily able to import Static Meshes, no problems, however after rigging, skinning and animating my character, it fails to import skeletalmeshes.

I try to import my mesh with skeleton, and it just recognizes as a staticmesh, despite having a skeleton.
It also shows me the message:
“WARNING: Asset does not appear to correspond to the selected type, and may not import correctly”

This shows if I select animation, or skeletal mesh.

If I export just the skeleton on it’s own with animations, and I try to import, it detects as being an animation, but obviously I need a skeletalmesh before I can import it.

I have been trying to export/import based on these links and I should note that I am not using the A.R.T tool.

Here are my export options from Maya (Also bare in mind I have tried various combinations of settings).

The error log tells me:
“Failed to find any bone heirarchy. Try to import as Rigid Mesh option enabled”.
(I’m looking into this specifically now to find a solution).

I am not trying to do anything too complex either. The character is pretty simple, with a basic skeleton with a really basic animation, so that I can work out the pipeline for importing skeletal actors and animations.
But seems I have hit a brick wall.
After about 3-4 hours of searching for answers, and trying a whole bunch of things, I have finally given up and come here to ask for help.

More than likely, it is something really simple and stupid on my end…

But I did just try the most simple set up.
I created a cylinder, I created a root joint, I bound them, I selected the mesh, I selected the root joint, and exported.
Tried to import and it gave me the same error.
I then selected just the root joint and immediately was recognized as animation.

So confused right now :frowning:

Thank you in advance.
Your help is appreciated :slight_smile:


I just decided to ignore the message, while also ticking the import option box “Import Rigid Mesh”, and it seems to import.
Except the skeleton doesn’t seem to have been imported at all…
And when I try to import the animation, I get the following error:
“Could not find needed track (testAnim_Mesh).”

Which I would guess occurs because there is no skeleton.

Same problem here. I am trying to import a skeleton mesh from Blender.


I did some further testing to try and find a solution. I seem to be getting closer to getting this to work, but further away from the method that is documented to try and import a skeletal mesh.

It should be as simple as:

  1. Select root joint
  2. Select Mesh
  3. Delete non-deformer history
  4. Export Selected
  5. Import

Here is where I am up to now which ALMOST works fully.

  1. Select everything, including controllers, constraints etc.
  2. Delete all non-deformer history.
  3. Export All.
  4. Import (this time it recognizes as a skeletal mesh with zero errors and the skeleton actually exists now too!)
  5. In Maya, select the root joint.
  6. Export Selected.
  7. Import (Recognized as Animation, used skeletal mesh that I just imported, no problemo!).

So it imports 120 frames, as that is how many is in my simple walking animation, and it is looping over and over, however there is no actual animation, the skeletal mesh is just in it’s default pose.

Still, this is not ideal, as I have a feeling this could cause issues later by exporting all.

Looking forward to some help on the matter.
Thanks :slight_smile:


New export process got me a bit further, however Maya could not export constraints for some reason, so my character’s animation is just the character swinging back and forward from the root joint at his hip, as opposed to moving his arms, legs, heads, hips, feet etc.

  1. Select everything, including controllers, constraints etc.
  2. Delete all non-deformer history.
  3. Select root joint.
  4. Edit>Keys>Bake Simulation
    Settings are at their defaults, except for:
    Channels: From Channel Box (I selected rotational and directional transforms in the Channels for the root joint)
  5. Export All (however turn off Bake Animations in FBX export options. As a result, got errors:
    “WARNING: Animation curve tangent type changed to user (35)” with the description saying: “The plug-in has changed some animation curves tangents type to User to ensure interoperability. This mode change will not affect the animation curves’ values <list of controllers/constraints>”
    “WARNING: Constraints export failed” with a description saying: “The scene contains constraints. Activate the Export constraints or Bake Animation options before exporting” (which is funny since the error occurs with/without “Export Constraints” turned on).
  6. Import (This time I tick the box saying “Import Animation” and name it “testWalk”.
  7. In Maya, select root joint again.
  8. Export selected (no change in FBX settings).
  9. Import to UE4 as animation (default settings).

After this, I check my animations. The testWalk animation is the only one that animates (regardless of whether I import a seperate animation or not), however it does the wierd rocking back and forward thing.
The animation I just imported however does absolutely nothing, but it does have 120 frames in it, as it should.

I tested the FBX by exporting, then importing into a new Maya scene, and found the same issues UE4 was having (rocking animation).
I realised that I was only selecting the root joint when baking animation. I had to select all of the joints before baking the animation. Now it works fine :slight_smile:
Now to try and make my new skeletal mesh as my player character :slight_smile:

Aaaaaand DONE, now I have a basic character with some crappy prototype animations of walk, run and jump.

I should also note, it’s my first time rigging, skinning, animating and importing any player character in any game engine, so i’m pretty stoked to have gotten it working.

I think that this pipeline will be the one I have to stick to, due to the complexity of animations I wish to do, which is fine, it’s a pretty easy pipeline. Certainly better than the 20-30 steps I thought it would take :stuck_out_tongue: