Download

Problem Map spawn

Hello,

I have made a map, but i have a problem with spawn.
When i enter in game, i’m not on the map, i’m like in heaven.

In UE4Editor i have created 12 spawn with id 0 to 11.

Anyone have the same problem?

Thank for help, if you need more information reply pls.

Seems like spawns are broken on my map as well (Terra Nova) I however have not tested or experienced this (cos i haven’t needed to yet) but i have had several reports that people who play my map spawn mid air only to start falling

Spawning with me however worked fine a few patched ago (last cooked 190 and it worked fine) and i have not changed a thing

I have this problem since about 190.
I spawn but i not fall. i’m stock mid air and I do not see the field.
Where is my landscape?

85e00f0d52729f9686ace91337ce3e4d46a7acb0.jpeg

If this is the cooked version of the map and you were attempting to load in when you had an existing save, your location may be incorrect because the x,y coordinate were restored for your character but they may be outside the boundary of your landscape. It is possible that the devs updated the default origin so maybe the coordinates changed, but I didn’t see any mention of that. Otherwise the problem may be the collision preset you have for your ground (but this doesn’t look like it is in editor so I assume you already tested successfully in editor).

Is the cooked version.
In editor i have the same problem since 190. Before 190 no problem.
Collision landscape: ground.

I have tested the teleportation command http://jdimensional.com/ark-map/ on different coordinate, but for all teleportation i die.

Can confirm, i had this problem when there was an existing save of an old map version. try deleting the old savefile.

Where ?
Here ? -> SteamApps\common\ARK\ShooterGame\Saved\SavedArks

I have the same problem in editor.

This also happens if you are streaming the levels (Using multiple .umaps) and didn’t specify that they should be loaded. Either always or via BP.

My map config

Persistent Level -> Landscape, weather, water.
All other level for rock and foliage.

bfb402b9fcc1047821d0b5e93d361c52b9bb0c34.jpeg

Did you copy the levels and transfer or did you copy the small_island project?

At the bottom right where it says levels you should have them all saved as Always Loaded, to test if that’s your problem. I know eventually you set this up through the Level Blueprint.

https://wiki.unrealengine.com/Blueprint_Manual_Level_Streaming ← This can help!

I have tested more and i found the real problem.

Watch the video.

https://youtube.com/watch?v=fYHMM_VyYP0

I walk and go out of the map ???
My map is broken ?

One idea ?

This one is news to me. :frowning:

Looks like you got to a spot without a collision preset?

yeah it look like what drathek said, you will need to look for all the collision preset for your landscape and need to change it to ground.

The collision is already set to ground.

0c03f57acd700f9f7882b5e11fcaf254c0f21868.jpeg

The problem is the same for each side.
It is as if there was a playable section and beyond this section, the floor disappears. After all map bug.

a923fd019d4f2c2671f6c00596cdbc615f11fb12.jpeg

Check where you have your water volume as i had issues with that until i set it properly, before i set mine up it was like a flat plane and at some points where it went just above ground id glitch out (walking and swimming) so i fell through the floor

I have tested, no water problem.
I have no idea what is the bug.

Okay, so I currently am having this issue after doing everything exactly the same as the tutorial video. In the editor, everything works as expected. But when cooked and uploaded, even after re-spawning, I am in some sort of mid-air standing fall thing in pure white heaven.

What the hell.

Does anybody know what I’m doing wrong?

I had the exact same problem. The culprit is in World Comp. Uncheck “Enable World Origin Rebasing”. That should make your entire map playable.

f65f677c3b0af86c5060aaaea492897779af9033.jpeg