Problem Making An Executable/Launching

I have a game with multiple levels that works fine whenever I debug it in the Unreal Engine. However if I launch it or make an executable it gets some weird behavior. First off all the text in he game becomes a series of straight lines. The menu won’t load any of my levels, instead just reloads the menu when I click the option. If I launch from inside a level then my player’s arms and gun are gone but they can still fire and here seems to be some lag issues too. Is this common behaviour? Is there a memory leak or something that could be causing this? I imagine the text issue is something to do with the fonts but I’m just using he default fonts you get when you create text in an actor’s components. Please can someone help me? This project is due in two weeks time and I really need a working executable for it.


In order to assist you further, I’m going to need a bit more information. Are you receiving any errors when you’re trying to launch or package the game? Were there any warnings/failures before you even tried to package the game? What version of the engine are you working out of? Can you possibly provide me with some screenshots that show what you’re describing?

Looking forward to hearing back from you!

Well I’m not sure how to picture it failing to load levels or having lag, but here’s the text issue on my main menu. The top one is when I play it in the debugger while the bottom is when I launch it.

Also here’s a list of errors that I get when playing in the debugger but I don’t think they’re related since they only pop up when I’ve been in the gameplay for a while. This problem occurs as soon as the launcher begins.

As far as I can see the launcher doesn’t report any problems when it’s building the game. It just takes a minute or two, finished building it and then I get this non working version.


When you created the levels within your project, did you actually go to Window > Levels and set up additional levels from your persistent level? Once you add the level in there, you can then include the level streaming volume and it’ll stream to the next level attached to your persistent level. Is this how you set yours up?

After looking over the errors within the third image you provided, it looks as if those accessed none errors are likely due to empty character references because there aren’t any IsValid checks.

Also, you said that you’re having trouble with executables as well. Have you been able to successfully package your project for Windows without encountering any errors, or are there errors within the output ? If there are errors in the output log, I’d highly suggest you provide that document to us for closer observation.


No, they are no errors when I make an executable. It basically gives me the same thing as the launch version. I just happened to notice it first there because I tried to make an executable before checking a launch. I haven’t done the level set up like you suggested but I’ll look into that right away.

I’ve set up all the levels under one persistent level but now it loads them all at once. If I launch it it even loads levels I didn’t include in my persistent level, ones that happen to be in the same folder like the minimal default level. I found this page how to make persistent level? - Audio - Epic Developer Community Forums which seems to have the same problem, which is then solved but it doesn’t explain how beyond setting Enable World Composition (which I did).


When you right click on the map in the levels menu, is the streaming method set to always loaded? If so, that may be the issue that you’re encountering. Here is an example of how mine looks, which the second level does not show up when I PIE or launch to Windows.

That doesn’t appear as an option for me :confused: I must have an older version of unreal than you. This is what my level looks like.


Which version of the Editor are you using? Currently, the newest version of the editor released at this time is 4.7.5. If you could please update your editor to 4.7.5 and create a COPY of your project, you should then see the same menu I see under the level editor. I’d like you to try what I suggested to see if it corrects the issue you’re currently running in to.

Thank you!

I’m using 4.4.3 and have been for several months. A friend of mine updated and an into some pretty major problems so I’m a bit reluctant to do that. I surely there must be a way to change it in my version somewhere. All I did was try to make a basic level and I ran into this problem.


Since you’re working out of 4.4.3, it would not override your current editor that you’re using. You simply would go to ‘+ Add Versions’ and select 4.7.5 to install. When it’s installed, you would COPY your project, DO NOT convert it. And then you would be able to test the level editor within 4.7.5 to see if you receive the same error.

In the meantime, I am installing 4.4.3 and will be testing whether or not I can work around what you’re stating is occurring. Looking forward to hearing back from you. :slight_smile:


Have you tried turning off World Composition? I’m in 4.4.3 and I see the level streaming capability within my menu, so I’m not sure why it’s not showing up on yours. However, I tested the World Composition and if it has a check beside it, the levels merge and show up all at the same time, if it’s not checked off, then the levels aren’t shown at once.

I hope this helps!

Hey. That helps…somewhat. I guess I should have tried it without world composition in the first place. What’s happening now is that my levels don’t all load at once but now my music and HUD have disappeared in game for some reason(?) and the problem of the menu text and not loading levels in the Launch version is the same. But that might be because I’m using Load Level instead of Load Stream Level.

Edit: Just tried Load Steam Level and that doesn’t work at all. Also the sound is back but the HUD is still gone which is really confusing as I didn’t do anything.


In order to assist you further with the additional issues that have came up, I would suggest you either providing detailed screenshots of your blueprints, along with a description of what’s going on and what you have changed or if you could provide me a link to your project. If you wish to keep your project out of the hands of the public, submit it to me in a private message on the forums.

Looking forward to assisting you further, thank you. :slight_smile:

Here’s a link to a git hub repository of my project.


I have been able to successfully package your project and run it without any trouble. There is an error that occurs when opening the .exe though.


Other than that, the game runs great, minus the words as they’re not showing up like they’re suppose to. Unfortunately, UMG was still experimental in this specific build of 4.4.3 so that’s not an option to correct the font within your project.

I will continue to test different theories on how to get your text to not be blocks so that you’ll have a full game.

In the meantime, could you please try to package your game for Win-64 and see if you run into any errors and tell me exactly which button you’ve pressed and what level it is that you’re running into errors on? So far I haven’t had any of the music cut out, and the text that appears when you first start a level also appears.

Looking forward to hearing from you! :slight_smile:

Were you able to load levels from the menu during the packaged launch? Because that’s the real major issue now. Also the text used to show up fine. This is my forth sprint of my project and I was able to successfully make launch versions for the last two. So it must be something I’ve done since then. [Here’s my which should detail all the changes I’ve made since it was working.][1]

As for the glitches, for me it’s really jerky and laggy. But more importantly some of the physics are just off, notably the jumping. When debugging it you can make the first jump on level 3 with the item you get while in a launch build it’s impossible. My HUD is also missing from both launch and debug, something that’s happened since I started messing with the shared levels.

EDIT: Okay I know why the HUD stopped working. For some reason combining the levels just deleted everything I had on my HUD. Irritating but all the bindings I used for it are still there so it was a quick fix.


Unfortunately, I cannot look at your report due since I do not have a log in for your domain. You can simply screenshot the if you’d like me to review the contents of it.

I have been able to successfully package your game as well as run your game without any trouble. I was also able to load into different levels. I receive a danger alert before I’m hit by an asteroid. Shooting the asteroid causes the asteroid to vanish, sadly no explosion yet! Being hit by the asteroids also sends me back to the main menu, with the ‘death’ music, I suppose it would be called. I also respawn when falling off of the platform, so that is all working fine.

I do not notice any jerking or lagging when I am playing your game. I do notice that the jumping is slowed, or the gravity is different from regular games. But I expect this to be intended due to the content within your game.

Just so you know, I am testing your game on a machine that has 32 GB of ram and a GeForce GTX 770. I’m not sure what your computer specifications are, but that could also be why I do not see any lagging or jerking while playing your game.

I’d also suggest implementing a lock feature on the mouse, so that other windows do not overlap the game while others are playing it.

Hopefully all of this information I have verified for you helps. Good luck and have a great weekend!

Yes, I do have different jumping mechanics to the default. It’s probably not as clear because the HUD randomly decided to delete it’s content. But in the game there is a fuel gauge on the top right that depletes over time and affects your jumping ability. However the behavior works very differently between when I jump in the debug and in the launch versions (and sometimes it acts outright inconsistent in the debug version too, something I’ve asked a question about [here][1] but have got no response for. This is very frustrating as it is a platformer and the levels have to be built around the jumping. If I can get semi competent jumping and the text working then I’ll be happy with the build and able to close this question. The level opening is working for me now too which just leaves me confused as to why it wasn’t working before. Bu that’s still a major step in the right direction. Also the lock mouse isn’t that big a problem as I inend for people to play the game using an XBOX controller.

Here is my screenshot.



Thank you for providing me this information. Since your original HUD wasn’t working when you sent me the project, I wasn’t able to test that. Since you have put in a new question for your jumping, I will make sure that myself or someone else on the team reviews it and helps you.

I’m glad that you have already chosen to implement a game controller rather than a mouse for your controls, due to the cursor not locking into the game window. That resolves that issue.

I have been able to successfully package, launch and play your game without any lag or crashes, so your initial question has since been resolved.

With that being said, this question can be closed at this time and we should move onto the other question that you have asked in AnswerHub. Since they’re completely different questions, they do need to be answered in different AnswerHub posts.

I appreciate all of the assistance you’ve given me with helping you resolve your initial complication with your project.