Problem in GameMode and about spawning

I’m following this YT tutorial

“Endless Runner: Spawning the Course | 02 | v4.7 Tutorial Series | Unreal Engine”

Endless Runner: Spawning the Course | 02 | v4.7 Tutorial Series | Unreal Engine - YouTube

But I just can’t spawn the “BP_FloorTile”

Then, I found this comment

I'm doing that, I have checked the Default GameMode in the Project Settings and make sure to set it to the right GameMode, but it doesn't work.

Then, I also found this comment

This one works, I changed the name from "RunGameMode" to "ThirdPersonGameMode" then the "BP_FloorTile" spawn as intended.
But then... I changed it back to "RunGameMode" and the "BP_FloorTile" doesn't spawn.
So I changed it back again to "ThirdPersonGameMode", but this time this doesn't fix it... now I'm stuck. (HELP)

Why is that? can someone explain it to me?

Hello! Check out Config/DefaultEngine.ini (GlobalDefaultGameMode), also World Settings for the map(it can override default one for this map)…

Hi! thank you for answering, I’m kind of new, can you tell me where to find them?

I found Config/DefaultEngine.ini, what am I suppose to do in there?

I see… I think I get it, Thanks

Its works, Thank you!

Search for GlobalDefaultGameMode, it can give you class that is used as Default in your project.