Download

problem importing fbx from 3dsmax 2014 to UE 4.5

Hi all,

Here are my rigged meshes in 3dsmax 2014 :

51b7ac69b0f8728a549ffdf4e2090871c75ee194.jpeg

There are 4 differents objects (2 hands and 2 arms) all rigged on the same bone system and every controllers are editable splines.

left hand modifier stack :
turbosmooth
skin
editable poly

right hand modifier stack :
turbosmooth
skin
editable poly

left arm modifier stack :
skin
editable poly

right arm modifier stack :
skin
editable poly

I named the root bone (shoulders bone) “B_root”, but other bones don’t have “B_” as a prefixe, nevertheless every bone has a unique name.

Here are my settings in fbx export dialog box :

Unreal Engine 4 :

Could you please tell me how to fix this ?

Thanks

My guess is you are exporting also the rigging, just export the model and the bones it is skinned to. Select only the model and bones and use Export Selected, in stead of Export. Also make sure no rigging is Linked to the bones, otherwise they will also be exported, regardless. You can have it Constrained, like using Link Constraint, but don’t directly link it with the link tool, so the rig can be separate from the bones.

I too beliee UE4 updated FBX version from 2013 to 2014, try that as well :slight_smile:

Hi Obihd,
Thanks for your replie. But if i export model and bones without rigging linked to the bones, how my animation can work in unreal engine4 ? How can i have a rig seperated from the bone ?
Sorry i’m total noob in UE4 animation.

Hi rubenst,
I had same issue with the 2014 version that’s why i tried the 2013 one :wink:

multiple roots found…are the arms two separate bone hierarchies??

If so, try adding in a new bone that acts as a root for both arms

The rig is just there to drive the bones, it should never be included as part of your skeletal structure when you create it and should never be exported. This is more specifically related to game rigging. For any other purpose, you can basically do whatever you like.

So, bones are never linked to the rig and the rig is never linked to the bones. You use constraints to drive the bones with the rig. If this is not the case right now, you might always have problems until you change that setup. When you use constraints, the two are technically separated, but one drives the other. It’s almost like remote control then. So if you constrain the rotation of a bone, to the rotation of another object, you can’t rotate the bone, but you can rotate the other object and the bone will follow. The bone then is not actually linked, but constrained, it’s still a completely separate hierarchy.

So anyway, with all that said, when you rig bones to dummy objects or whatever you use to create your animation rig, you animate the rig, the bones will follow, right. When exporting the bones alone, Max will respect this animation that is being driven by the rig, and basically “bake” it to the bones. So after export, you no longer have the rig in the FBX, but you have the bones and they are still animated.

as i said earlier, the arms have a a common parent : the root bone (shoulders)

i shouldnt add the rig inside my bone hierarchie ?
thumb bone < thumb controler (rig : editable spline) < hand bone < hand controler (rig : editable spline) < arm bone …
So it is wrong way to do so ?

By constraining remote controls to bones you mean that i shouldn’t link them BUT i should use only wire parameters ?

I see, i understand now, thank you very much. In the future i’ll rig and export this way

No, don’t do this. What it means is you basically have two skeletons mixed together. There are probably exceptions that will be ok, but it’s better just to not do it. Keep your character skeleton clean without anything else linked to it that should not be part of it.

Yeah, you can use wire parameters. It’s essentially the same as using the constraints. As long as you don’t do straight links, you should be fine. So with that, you can do Export Selected and keep your exports clean from rigging or anything else that might float around in your scene.

So, if you did this and you still get hierarchy errors, then of course it is your actual skeleton. What you should probably do is just simply delete the whole rig (just for testing) and then export the mesh and skeleton, and see if UE4 likes it or not. This way you at least know if what needs to work, works. Then you can deal with the rig as needed.

Thanks so much again :slight_smile: i’ll keep you updated of the process

Edit : is it ok to use editable spline as rigging controllers ? Or should i use polys instead ?

It’s fine, you can actually use anything you want as rigging.

Hi,

As expected it worked fine :slight_smile:

I could import the new rigged models as a single skeletal mesh in UE4.

b99461b7a26b5719661d92b32788cc8349933703.jpeg

999bdc5d1bf65acc2f243677f1a3c8358297b58c.jpeg

I skinned the hands on a low poly res mesh, which is much easier (vertices by vertices instead of using enveloppes), so i exported the .fbx file with “turbosmooth” turned on as you can see below

left hand modifier stack :
turbosmooth
skin
editable poly

right hand modifier stack :
turbosmooth
skin
editable poly

I thought that UE4 would take account of this but it’s not the case. The low res polygons have been imported as hands meshes :

I said to myself “ok i just have to collapse the modifiers stack in 3ds Max 2014”, but if i export the fbx, the hands disappear in UE4. there has to be a skin modifier above the editable poly in the stack, so i added it, added the bone and it distroyed all my previous skinning (which i think would have been baked in the editable poly when i collapsed the stack). Also i tried to move the turbosmooth modifier below the skin one and it also ruined my skinning because no weight has been set up for my extra geometry.

What should i do please ? I don’t wanna redo the skinning on a high poly res wich is a NIGHTMARE for hands with enveloppes (i have already tried). How to easily import in UE4 a high or medium polygonal resolution from a skinned low poly res ?

I solved my problem by using the skin wrap modifier in 3ds max

Hi all,

Now i have my medium resolution poly arms imported in my UE4 project.
Is it normal that the mesh is not smooth ? (i checked “smoothing group” in the 3ds max fbx export dialog window)

0b72060d320ee2011fd5f63b3f22f810c05bd25e.jpeg

And how can i enable “2 sided” in my arm material please ?

8b3658007eef92063fc2389340e58a097183aacd.jpeg

26.jpg

Thanks