Download

Problem if car import or I do not know...

Hello, I’m french if I’m sorry for my level speak english. ( I used translate google, sorry)

(J’ai un problème, j’essaie différente méthode pour utiliser ma voiture que j’ai créée
et je n’arrive pas à faire rouler ma voiture, j’ai fais tous les tutoriels vidéos, et par manuscrit, et rien ne fonctionne chez moi…J’utilise Cinema 4d et, c’est là, où, j’ai créée la voiture et je vois pas mon problème…Aidez-moi, s’il vous plait. Je vais finir par pété les plombs, ça fait longtemps que je fais ça et j’ai rien trouver, je dois porter la poisse quand j’ai fais.)

I have a problem, I try to use different method to my car that I created and I can not roll my car,
I did all the video tutorials, and manuscript, and nothing works for me … I use Cinema 4d, and this is where,
I created the car and I not see my problem … Help me, please. I will eventually lost it, it’s been that
I do this and I find anything, I have to jinx when I do.

Please help ! thank you beforehand, cheers, Bastien…

Help, please.

its hard to guess where the problem is, first the root bone MUST be at 0,0,0 axis MUST be X=Forward and Z=Up
if you are not using bones then the pivot of the main section must be at 0,0,0 But the mesh needs to be above 0 and the bottom of the wheels neeed to be on the ground
i don’t use C4D so i’m not sure where else i can help, a few pictures of the set up before export and in editor might help

Voici, les images. (Here, the images)

ok the issue i can see atm is the pivot of the vehicle-bone is above the ground it needs to be at 0,0,0 i’m not sure how you would do that in c4d

Is what atm ?

I’m still not sure what’s your exact problem.

The only thing i see so far is that your hierarchie isn’t the usual fbx setup.
Usually you have a null object that contains the skeleton and the mesh.

For example:
ff7ff3a4f37f6ac237c8a6eb46e474af0365e89d.jpeg

If your model turns out to be imported correct anyway, i guess your issue lies elsewhere.

Not sure which tutorial(s) you followed, but with the information currently given by you,
the issue can be anything from bugs in coding/blueprint to lack of animations and correct animation setup.

My problem is that I can not move the vehicle. There is the wheels which rotates correctly. And it is there that it annoys me. ^^

And I wanted to know if my export setting the FBX format is good?

60f65f83cce6d4de138874567671bccd0c38de79.jpeg

This would be in cinema 4d qu’ça is the problem? I think I need to add?
How to Put the orange triangle? We can explain? Please ?

ok since your using c4d i suggest you start very simple eg a box with 4 cylinders, then create a skeletal rig with a root bone and 4 wheel bones, the root bone must be at 0,0,0 the other bones in the middle of the cylinders, make sure that the bones are aligned X=forward Z=up now parent the 4 wheel bones to the root bone, join/merge the cylinders to the box, skin/weight the verties of the box to the root bone and the clyinder vertices to the wheel bones now export via fbx to ue4 to test, please show pictures of the result in c4d and ue4 with show bones/axis option applied

yes this takes time but once you learn the procress then you can move on to more complex vehicles

Tried it myself, i guess now i understand what you meant. Quiet a crazy dance it performs.

The issue is the physics asset. When importing a new skeletal mesh, it needs to be adjusted otherwise it’ll act like this.
You might be able to use the physic asset from the example car for testing.

I hope to be good.

C4dprimer16 :

3e7179b5a37d7e13d20db12f5ebcce40d27dd5f0.jpeg

Ue4 :

2783f5b634bac3d7d4dca9de41292074c68149ac.jpeg

ok still having issues here i see, ok when in the ue4 editor (your picture) click on “Show” and tick the box “Bones” this will then show the bone pivots and axis

i don’t know how to help you on the export side but i found an old thread with the same sort of issues exporting to unity game engine http://www.c4dcafe.com/ipb/forums/topic/77092-c4d-to-unity-3d-z-axis-issue/

also try using google to search for help “cinema4d ue4” might help with setting up c4d

No need for having the mesh laying on the side, it’ll import correctly unless there is a custom animation applied. (bug)

After importing the mesh itself, you have to change some more things in the blueprints in order to make it work.
Like if you change the mesh in the vehicle blueprint, the physics asset and animation blueprint need to be reassigned to the new mesh.
Also, the animation blueprint still referes to the old models skeleton, so you either need to assign the old skeleton to the new mesh (quick and easy way),
or you need to edit the animation blueprint to work with the new skeleton asset. (in case you had to change some bone positions to matcch your models wheels)

I’ve tested it with the advance vehicle and added a Figure to the mesh, works quite well even with exporting from C4D.