Problem FPS with UE4

Branch: ‘Binary’ build from the Unreal Launcher

Build version: 4.6.1 - 2386410

Detailed description of the issue: I have some problem of FPS in UE4. When I am in the Fullscreen mod I have more FPS and when I open a new window like Blueprint, I have less FPS.
Look the video for more detail

Repro Steps

Action 1 (Watch FPS))

Action 2 (Press F11 (Fullscreen mod)

Action 3 (Open a Blueprint)

Action 4 (There is less FPS)

This issue occur 100% of the time.

System Specs:
Windows 7
NVIDIA Geforce GTX 970
I5 3550
Gigabyte Z77-D3H
Corsair DDR3 2*4
Screen : VA2231 Series, Acer AL1951, BenQ GW2760

Thanks you!

Hi ,

Thank you for reporting, but this isn’t a bug. The editor requires it’s own resources to render the windows that are visible on the screen. When you go to full screen mode the editor windows are not being rendered freeing up the FPS in the editor window you see. The same is true when you open the BP and see the FPS drop.

The editor veiwport FPS is not a true indication of the FPS for your final game. If you want to look at the FPS in that way I would suggest placing the editor viewport to not be real-time and to launch your game in Standalone Game Mode from the play options. When i do this on my home PC which is mid-range at best, I see FPS of 120-140 compared to ~70-80 fps in the viewport with the editor visible.

I hope this helps explain a little about what you’re seeing.