Problem Exporting from Substance Painter

So, this is something that has been driving me crazy the past day… because it was working before for me. I never go on forums so forgive me if this is in the wrong place. This is also the first time I have ever written a thread, and i’m self taught in everything that has to do with 3D. I feel like this issue is too complicated for just typing it in google and hoping for a response already there.
Let me tell you what is going on, so I have these assets that I am creating in MODO, which I transfer to Zbrush for high level details, lower the resolution, transfer to MODO again for UVing, and finish with substance painter then exporting to UE4. This has worked fine for all the other assets I have, (except for the scale, my object shows up smaller than a leaf of grass, but this is a separate issue). Anyways, I have attached a picture of how everything is looking so far, and hopefully I can explain this well enough.

I import my mesh, with base color, normal, and OcclRoughMetalic (RGB). I then assign them in the material editor accordingly, and I get this (picture 1). This is normal. This is the way I have done and tested every single asset. Even the one that is giving me trouble was working before in the exact same way. Well, I decided to start building my scene, and nothing was changed settings wise, I just imported everything and all was good. When I imported this one mesh (picture 2) it looks like that… and I have tried everything, from UVing again, to exporting and starting over… and nothing works.

A few things about this mesh that I found very very interesting. When I export the textures in 2048 resolution, it looks as it should, but when I export in 4096… (like the rest of them have been), it breaks…

Something else, when I remove the base color node, I get this (picture 3) which looks like it is supposed to to my knowledge… This is driving me INSANE. I also checked all the settings in comparison to all the ones that ARE working, and they are identical.


On a separate note, about the scale issue I mentioned before. I am measuring everything from MODO and exporting according to the scale I set in MODO for reference (2 meters). When I export as OBJ, which is the only way I can work with Zbrush and MODO back and forth, it shows up in UE4 smaller than a leaf of grass… literally. It doesn’t bother me so much that it is turned on its side because its not hard to fix, and its normal sometimes between different software as far as i’ve heard… but its annoying to have to increase the scale from 1 to 80 all the time.

Excuse my ignorance where its due please since I am self taught as mentioned before… its a steep learning curve :stuck_out_tongue:

Thank you!! The first issue is more important to me btw.