Problem downloading dependencies in Windows 10?

Grabbed the latest .zip of source onto a new machine, unpacked it and ran setup.bat. Watched the “Updating dependencies” counter spend a while building up to 99%, then fail with this:

Checking dependencies (excluding Mac, Android, Linux)...
Updating dependencies: 99% (22123/22124), 3130.3/3131.0 MiB | 4.78 MiB/s...
Failed to download '': Can't  from pack stream (CorruptPackFileException)

Initially thought maybe I had a network problem near the end since it had gotten that far. Tried again with the same result.

Then tried this again on another machine, and it works. The main difference between the two machines is Windows 10 (didn’t work) and Windows 8.1 (did work). So now I’m not sure if this is a problem specific to Windows 10 or something else with that machine.

Hey jmp0-

When you mention getting the latest zip of source code, which branch are you getting the source for? If you are on the master branch then it’s possible that there was an issue at the time of downloading the .zip and I would suggest downloading and trying to run Setup.bat again.


This was on the release branch.

Hey jmp0-

I’ve tried running Setup.bat on a Windows 10 machine on my end and was able to do so successfully. Can you try re-downloading the GitHub source and try running Setup.bat again. Additionally, what is the file path where the source code was unzipped to? It’s possible that the path is too long, try moving the engine folder closer to the root directory before running Setup.bat to see if that helps as well.

Just re-downloaded the release branch .zip, unpacked it to d:\UnrealEngine-release, and ran setup.bat. Same problem - it gets to 99%, and errors-out.

Checking dependencies (excluding Mac, Android, Linux)...
Updating dependencies:  99% (22122/22124), 3105.0/3131.0 MiB | 2.97 MiB/s...
Failed to download '': Can't  from pack stream (CorruptPackFileException)
Press any key to continue . . .

This is on my Windows 10 desktop machine. Doing the same process, using the same .zip file, same destination paths, etc. on my Windows 8.1 laptop completes successfully.

Hey jmp0-

Does the Windows 10 machine use Visual Studio 2013 or 2015? Also, can you double check that you have the Windows 10 SDK installed? If you’re still unable to run Setup.bat after these steps I would try removing the “-” from the “UnrealEngine-release” folder name in case the special character is blocking the file location from being correctly.


I’m using Visual Studio 2013.

I ran the Windows 10 SDK installer today just to make sure.

I tried removing the ‘-’ from the directory name.

Still the same problem. I’m not sure how any of those things would cause an error 99% of the way through the download. Unless it is a bad error message, it’s saying it cannot complete the download. Or possibly the download completed but it detected corruption.

I have noticed there is a slight inconsistency to where the failure occurs. If the counter is to be believed, it is always at 99%, but the actual size where it fails is always a little different - in the two examples above it fails at 3130.3 and 3105.0.

I thought maybe it was an anti-virus issue - the two machines run different anti-virus software, so one thought I had was maybe the anti-virus was killing the file as soon as it downloads on the Windows 10 machine. So I tried completely disabling the anti-virus software and doing everything all over again, but I still get the same problem.

I’ve determined this has something to do with a SonicWALL hardware firewall at the office. Machines running through that firewall have this problem, those that are running through a different firewall do not have this problem. So this is definitely something on our end. Sorry for the trouble.

Are there any other workarounds to this? I’m running into the same issue on a Windows 8.1 Enterprise machine with McAfee, and I’ve tried disabling all the relevant McAfess services but I’m still running into the CorruptPackFileException. Alternately, is it possible to download the zips stil

Hi ,

Unfortunately we do not have any machines with McAfee installed, so I can’t do any testing for that. Did you confirm that you had temporarily disabled any firewall before downloading the dependencies?

We do not have the zip files available any longer. The current format for downloading the dependencies allows us to more reliably ensure that the correct dependencies are downloaded and installed for the version of the Engine that you are trying to build. The initial format of providing the dependencies in zip files was prone to errors where the wrong files were downloaded and used.

Alright, I figured it out if you’re having issues with SONIC Wall. As my admin was away for a week…

I used .NET reflector to change the base URL in DependencyManifest.cs, line 10 to https, instead of http.

If you don’t have access to .net reflector, here’s a download:

(Replace the one at \Engine\Binaries\DotNET)

I was just setting up 4.10 and had the same problem. Our IT department confirmed we have the Sonic Wall also. Litruv’s solution solved the problem, but is it possible Epic could make a fix so we don’t have to do this when getting new versions?

Hi mdegeorge,

I just wanted to confirm your experience with being able to download the dependencies through a SonicWALL firewall setup. Were you able to change the base URL from http:// to https:// and it worked for you, or did you use the executable file that Litruv provided?

If you changed the URL and it worked for you, we may be able to make that change on our end as well for future versions. If you used Litruv’s executable file instead, we will need to do some further investigation into what may be occurring in the interaction between SonicWALL firewalls and the dependency download.

Hi ,

I had the same problem and changing http: to https in DependencyManifest.cs fixed it. Be great to have that in the git source code.


Thank you ! It worked like a charm :slight_smile:

Thanks for the updates everyone. I have entered a ticket to look into the possibility of making this change on our end in order to simplify the process for users using SonicWALL (UE-29592).

Hi ,
We were also experiencing this issue and the suggested work around above, recompiling GitDependencies.exe with a HTTPS url worked for us, however our IT department looked at it and found some insights that might be helpful.

Apparently the Gateway Anti-Virus is detecting it as a worm, in our case it’s detected as Conficker.gen. Our IT department has added an IP address for to the bypass list, but obviously this might change and is probably not the best longterm solution.

URL Tested:

SonicWALL Alert

Hope this info helps.

We don’t have a SonicWALL, however download still fails with:

Even if changing the BaseURL from http.// to https:// in the DependencyManifest.cs, download does not seem to use the https:// version. Does GitDependencies.exe need a recompile, and if yes, how to do so?

I fixed this issue by using **gitbash.exe** instead of **win10 cmd.exe**.
Download gitbash and use it instead of cmd.

Second solution: When the downloading stops in the gitbash** or in **cmd window just Disconnect the internet and reconnect to start downloading.