Download

Problem creating a project unreal engine c ++

Hello, when I create a project unreal engine in C ++ it makes this mistake:

The project could not be compiled. Would you like to open it in Visual Studio?

Running D:/Programmes/UnrealEngine/UE_4.22/Engine/Binaries/DotNET/UnrealBuildTool.exe Development Win64 -Project=“C:/Users/Rémy/Documents/Unreal Projects/S_iRe/S_iRe.uproject” -TargetType=Editor -Progress -NoHotReloadFromIDE
Creating makefile for S_iReEditor (no existing makefile)
@progress push 5%
Parsing headers for S_iReEditor
Running UnrealHeaderTool “C:\Users\R?my\Documents\Unreal Projects\S_iRe\S_iRe.uproject” “C:\Users\R?my\Documents\Unreal Projects\S_iRe\Intermediate\Build\Win64\S_iReEditor\Development\S_iReEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for S_iReEditor in 9,1062282 seconds
@progress pop
Using Visual Studio 2019 14.22.27905 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.22.27905) and Windows 10.0.16299.0 SDK (C:\Program Files (x86)\Windows Kits\10).
Distributing 11 actions to XGE
--------------------Build System Warning---------------------------------------
License is invalid:
License information is invalid. Please try reloading your license file using the Coordinator Monitor application on the Coordinator machine, or reinstall IncrediBuild.
This build will run in standalone mode.


--------------------Project: Default-------------------------------------------
SharedPCH.Engine.cpp
c1xx: fatal error C1083: Impossible d’ouvrir le fichier interm?diaire du compilateur?: ‘C:\Users\RǸmy\Documents\Unreal Projects\S_iRe\Intermediate\Build\Win64\S_iReEditor\Development\Engine\SharedPCH.Engine.h.pch’?: No such file or directory

Error executing D:\Programmes\UnrealEngine\UE_4.22\Engine\Build\Windows\cl-filter\cl-filter.exe (tool returned code: 2)
Default.rc2 (0:00.28 at +0:00)
---------------------- Done ----------------------

Rebuild All: 0 succeeded, 1 failed, 0 skipped

1 build system warning(s):

  • License is invalid

I uninstall and reinstall visual studio with the c ++ stuff that can exist but it makes me wrong again.

thanks for the answers.

have you tried this, unsure if its related

https://answers.unrealengine.com/questions/218266/unable-to-start-program-ue4exe-error.html

Use a path that doesn’t have Unicode characters in it, e.g. remove this part -> C:\Users\R?my

UE does not like weird characters in the path.

Thank you for your answers. I had to change the way and walk. Thanks anyway.

Hello anyone :slight_smile:

I just want to mention that I had a build problem in c++ which turned out to be that one of the folders were encoded in non-English characters.
When switching folder paths to have only English characters it worked just fine.

I use Visual Studio 2019 Community edition with UE 4.22
Hope it helps

Im having this issue and i dont know if this forum has anything to do with it:
UATHelper: Packaging (Windows (64-bit)): ERROR: Unhandled exception: System.IO.IOException: Cannot create “X:\Documents\Unreal Projects\LanzaroteExplorer\Intermediate\Build\Win64\LanzaroteExplorer\Development\Engine” because a file or directory with the same name already exists.

That error pretty much explicitly tells you what the issue is. You’re trying to package your project to a folder that’s already in use. You need to package to an empty folder, not the folder your project is in.