Problem changing the default spawn character

My project was created using the 3rd person template.

I change the Default Pawn Class to DefaultPawn in Project setting. Ohter settings were untouched.


I started the game, but the default pawn class is still the Third Person Character. I don’t know why.

One thing I discovered was that if I deleted this Third Person Character in the level generated by the template, it worked.

I think this is strange and wonder if there are some ‘hidden’ settings to change the default pawn class.

Hi! DefaultClassPawn mean - this class will spawn on player start position when game starts (when loaded your level). Try these manuals for more information:

The AutoReceiveInput in my ThirdPersonCharacterBP is set to Disabled and its InputPriority is set to 0, by default. But this problem still exist.

Is it possible that the Third Person Character generated by the Third person template is different from the one we drag into the level?

The default map have both a PlayerStart Actor and a ThirdPersonCharacter.

If I delete the ThirdPersonCharacter, it will be spawned in the location specified by PlayerStart Actor. If not deleted, the PlayerStart Actor will not work, no matter where it locates. This is wired. Do you know why?

It was not set to ThirdPersonGameMode before I see your answer. Now it is set to ThirdPersonGameMode.


But when I started the game, it still did not spawn the DefaultPawn, which I specified.

By the way, I opened this map in ThirdPersonBP > Maps > ThirdPersonExampleMap.

Can you make sure your level’s game mode is set to your ThirdPersonGameMode?

You can also see this in WorldSettings tab if you open it from Window->WorldSettings

1 Like

Ok. Don’t use GameModeOverride if you don’t need it (if this map you will use default game mode).

  1. Create a new character (name it somehow - example: MyChar).
  2. Add this MyChar to GameMode as default pawn.
  3. Disable auto Auto Posses Player In Pawn settings (ThirdPersonCharacter).

This is it)

1 Like

Wow. It works!

I saw the 3) in your answer, and go to check Auto Posses Player In ThirdPersonCharacter. It was originally set to Disabled. I changed it to player0 > compile > changed it back to Disable > compile. Finally it worked! The DefaultPawn was spawned after hitting Play button.

Thank you so much for the answer!

Auto Posses Player is originally set to Disabled but takes effects like it is set to player0. I think this is a bug.

Got it. That was the ‘hidden’ setting (for me). lol

If you have a ThirdPersonCharacterBP in your level with AutoReceiveInput set to Player0 (or 0-8), you may have this problem. Setting should be disabled.


I had no idea there was a world override for gamemode, that is amazing to know! I had no idea the new third person template in UE5 defaults to overriding the gamemode. This was super helpful, thank you.

1 Like