Download

Problem/Bug with FBX Import from Maya?

So I got UE4 4.14 today and I noticed a bug type of problem. I searched google but nobody reported this yet. So I thought maybe I’m doing something wrong?

I’m using Maya 2017 currently and I noticed that no matter what I set in the FBX Export settings>Scale factor, UE4 completely ignores the data and imports the FBX in it’s original units. I don’t have this problem with 4.13 or older versions but only in 4.14.

So what I did is that I created a BSP 100uu100uu in UE4 and a box in Maya that is 100cm100cm and I exported it with a scale factor of 1.0 (So no unit conversion), so far so good. Problem is if I set the export scale factor to 10.0 (cm to mm) the box should get 10 times bigger (Which does in 4.13 and older) but in 4.14 it’s the same size

Heres a couple of screenshots:

d5258d55748e57e9e8300749b5bf54fea0a80422.png

Capture.PNG

Ah Solved it!

Apparently I didn’t read the 4.14 notes and it turns out you guys added an option in the FBX importer that converts the FBX units and Up axis to UE4 units and orientation. Fixed it by unchecking it.

Here’s a screenshot:

Capture.PNG