Download

Probably critical bug performance related

I’m not developer and i’ve tested so far two leaked (or not leaked? whatever…) technological demos: Elemental and Realistic Rendering (the room) and i’ve found out weird problem. I understand, i’m aware, these demos are not for public and they may contain bugs, etc.

First… Technical specification of machine:
Windows 8.1 update 1 Enterprise x64
CPU: AMD FX-8320@4,0GHz
RAM: 16GB DDR3
GPU: Gigabyte Radeon HD7790 1GB OC
Soundcard: Cerative X-Fi Titanium
PSU: OCZ ZS550
GPU driver version: 14.3

As display i’m using 37" tv connected via hdmi and to make text more readable in web browsers and other text-related software i’m using available in OS option of dpi scaling. I’m usually disabling it for games in properties of game executable file because in games dpi scaling sometimes causes some UI/HUD problems. By this habit i disabled dpi scaling for these demos and here problem appears. When dpi scaling is disabled for specific .exe performance of demo dips down 40-50%.

Realistic Rendering (aka the room):
with DPI scaling: avg fps is 45
without dpi scaling: avg fps is 90

Elemental:
with dpi scaling: avg fps is 36
without dpi scaling: avg fps is 23

When i check in properties of executable option “Disable display scaling on high DPI settings” fps is going way down.

Hi spectatorx,

What steps are you taking to reproduce this effect. I have tried two different approaches, and in each instance was unable to reproduce the fps drop you describe.

Trial 1:
I ran the realistic rendering sample without DPI settings disabled and at standard DPI computer settings, the FPS was ~60.
I left my computer DPI settings at the standard scale, however I manually disabled DPI settings in the editor. I then ran the realistic rendering sample and it stayed ~60 FPS.

Trial 2:

I adjusted the custom resolution for DPI scaling to 128%, then I ran the realistic rendering example and it ran at ~60 FPS.
I then disabled the DPI settings for the editor and ran the realistic rendering example, which stayed at ~60 FPS.

Any additional informaiton would be greatly appreciated!

Ok, i will try to provide as detailed informations as possible. If you will still have any question feel free to ask, i will be glad to help.

Let’s start it… from settings on my pc.

This is level of dpi scaling i’m usually using on my tv:
Imgur

Here are ccc settings:
Imgur

Way i reproduce problem:
First i run the demo without disabled scaling, to be more specific i mean this option in properties of executable file:
Imgur

This is framerate i get with these settings:
Elemental:
Imgur

RealisticRendering:
Imgur

But when i check the checkbox to disable dpi scaling for executable, just like it is shown on this pic:
Imgur

Framerate drops way down like this:
Elemental:
Imgur

RealisticRendering:
Imgur

And this is how gameusersettings.ini is configured for both demos:
Imgur

As you can see to exclude any limitations of fps v-sync is disabled.

Hi spectatorx,

Unfortunately, I was unable to reproduce this on our end. Can you post this to the answerhub at http://answers.unrealengine.com for further assistance? Thank you!