Download

Print String Not Working

Hi

Print string has stopped working in one of my blueprints, any Ideas.

It is working in others.

Regards

Shaun

Find in which blueprint it stopped
Then fix connections, check if that blueprint is triggered etc.

I know which one it stopped in, have even tried to use it with a keypress in that blueprint.

It is working in the other blueprints.

Try with BeginPlay node just for test

It works with BeginPlay, but I cannot get it to work on any keypress.

Maybe you need to enable input on that BP.

Also, if you have the same input in 2 blueprints, the 1st one will happily consume the input. So maybe something else is eating it.

@Muntrax, thanks, not sure how it would have got disabled, but would of not known
how to enable it. :o

@Everynone, I think what you said was the problem, I had PrintStrings in a number
of BP’s, I disabled them and it is working. Just my 2 cents, but I cannot understand
why that should be a problem!

Just a guess as I’m not sure what your setup is. You’d have to show us a screenshot of the blueprint with the Print String not firing.

The thing is that it’s not the Print String that is the culprit here. I’d blame scripting logic.

I mentioned keys consuming input as this is the default setting:

Capture.PNG

If you do this in 2 different actors and in the Player Controller, only one of the actors will fire, consuming the input. The controller will not even see it.
Actors also need to receive input first in order to register it.

It looks like that part of blueprint (one with print) is never executed. Move that print node closer to source, see where it starts/ stops printing.

@Everynone Screenshot attached.

@Nawrot It is working now in the BP with the exception of when I use a keypress. I don’t really need it anymore
as the BP is finished, but it would be nice to know what has caused it or (WHAT I HAVE DONE TO CAUSE IT).

Picture.png

And where was the Print String that did not work?

Hi Everynone

When I initially posted it had stopped working completely, then a suggestion was made to try with BeginPlay where I found that it was working.

I noted your suggestion and got rid of all the key presses and PrintStrings in other BP’S, it then worked wherever I plugged it in, but at this point it will
still not work with a keypress.

There are no key presses and no PrintStrings in any of the other BP’s.

I tried on several keys, when I was trying to get it to work, probably half the Alphabet.

Go to class defaults of this actor and ensure the input is *not *disabled:

Capture.PNG

Hi Everynone

I have attached screenshots from two different BP’s. The input is the same on both of them, but
the PrintString is only working in one of them.

As I said earlier it is not a hassle now as I am done with the BP and will not need to use the
the PrintString there anymore, it would just have been nice to know where it was stuffed up, by
me or if there is another issue.

Screenshot-20180813-12.42.36-FILEminimizer-FILEminimizer.jpg

Screenshot-20180813-12.48.40-FILEminimizer-FILEminimizer.jpg

Regards

Shaun

Do they both have Auto Receive Input enabled? Do you use Y or T in any other blueprint?

Hi Everynone

I am using W, A and D for axis mappings and Z for a teleport function. Nothing else needs getting
pressed to play the game with the exception of LeftMouseButtonDown for firing a projectile, so no
Y or T in any other BP.

Please excuse my ignorance to the 1st question, but is the attached circled in red what you are looking
for or something else?

Regards

Shaun

Yup, I even posted a pic above. Change it to Player 0.

One note here, the blueprint you see in the Content Browser is a template - you can change this setting there, too - so every new instance you place in the level will inherit it.
However, once an instance is placed in the level, you can alter this setting on per instance basis.

Hi Everynone

Thanks for persisting and the time and effort with a noob.

Regards

Shaun