Print string doesn't work


I can’t print strings, however if i replace print string node with quit game node, game quits.


I tried using begin play, i tried different blueprint classes, nothing works.

This issue doesn’t appear on a clean project

Hovewer, lately i am experiencing lagg when trying to play game in editor. When i press the play button, it laggs for about 1 - 2 seconds and then starts the game. Before that started happening, i could always print strings.

One reason you might not see them is if the extended options are changed:


Does it behave any differently in standalone or on a dedicated server?

Check your fonts.
Project Settings - General Settings - Fonts - Small Font.
Print will not shown with it set to “None”.

It’s set to roboto (i presume it’s default font that engine uses)

Default print string options have not been changed, however if i launch this project on my phone it prints the string.

Most likely you would have noticed it by yourself but you did not set:



in DefaultEngine.ini in project Config folder?
Can’t remember any other way to disable Print on screen…
Does Output Log window show message?

Something strange just happened. I did not do anything to my project after posting this question, i just closed the editor. Now i opened my project again and everything works fine. Thank you for your help, anyways :slight_smile:

This issue has been resolved by restarting the editor. I should have tried this before posting this question.

When restating my editor nothing happends its still broken