Download

Prgram cant start cause api-ms-win-downlevel-kernal32 blah blah dll is missing

WTH? Same boat. Do something, Epic.

Had this error earlier after restarting the Epic Launcher:

SystemTray: EpicGamesLauncher.exe - Entry Point Not Found
The procedure entry point dbgcore.MiniDumpWriteDump could not be located in the dynamic link library dbghelp.dll.

Restarted the launcher and the error didn’t come up again.

Then why do you share download urls to it? Please do not help people ruining their computers. I’d like to ask a mod to update his post and remove the url if possible.

Additionally to the Telemetry reports, there are known system wide issues with kb4507456, which i just found out on the following sevenforums url, but google also has more about this particular update.

https://www.sevenforums.com/news/420245-july-9-2019-kb4507456-security-only-update-windows-7-a.html

Everyone is aware it’s telemetry, but it resolves the api-ms-win-downlevel-kernel32-l2-1-0.dll issue, so it’s download at your own risk.
I’ve been on sevenforums over 10 years and knew about this issue since the update was published, no one has reported any fatal system error as a result of applying the KB4507456 update.

Can you further elaborate how KB4507456 “ruins” people computers? Can you give specific examples on how update KB4507456 would cause people’s computers to be “ruined”? Which operating system(s) does it affect or is this just your personal emotional opinion?

Please read the conversation, people have report system wide issues (performance problem) and the additional KB4512816 is noted to fix issues (boot related apparently) caused by this particular KB. But the real issue is people have already recognize the existence of telemetry which is a security problem. Just keep this in mind and perhaps reconsider your recommendation with that url.

The dll problem might be resolved by that particular KB, but i’m sure there must be other ways to get this fixed without forcing people into unwanted windows updates and alike. Epic should fix the launcher, it was working fine prior these launcher updates, so this dll must be something trivial that doesnt justify desperate measures on users end.

@VictorLerp @Amanda.Schade cc [USER=“9”]Stephen Ellis[/USER] @Sam_TinFoil cc @CoquiGames

Bumping topic as Epic need to resolve this. So overall ^ this ^ point still applies.

Why?

Microsoft TELEMETRY = Surveillance. Windows & Office telemetry in Europe is illegal (in breach of GDPR)! :mad: That’s why Microsoft products have been banned in Germany and they’re being investigated in the Netherlands and elsewhere. We all know where this is going though, right? Feed the AI / Algos…:mad: Watch The-Social-Dilemma or The-Great-Hack on Netflix or this on YouTube. It shows China today, but its us tomorrow. :wink: After all, Microsoft promised Wall Street bankersLIFETIME monetization of Windows-10. So are the ‘rent-seekers’ at Microsoft going to save 200m Windows-7 holdouts from telemetry? Yeah right - dumb question!!!:stuck_out_tongue:

https://www.zdnet.com/article/window…ses-your-data/
https://www.zdnet.com/article/window…-data-privacy/
https://www.zdnet.com/article/micros…privacy-fears/
https://www.zdnet.com/article/micros…use-your-data/
https://www.zdnet.com/article/dutch-…n-breaks-gdpr/

2 Likes

Windows 7 user here. I am having the same problem. Epic Launcher fails to open. I get an error message that I am missing api-ms-win-downlevel-kernel32-l2-1-0.dll . This started happening around 4-5 weeks ago.

Yeah this worked for me too. Thanks to original poster!

I downloaded the launcher installer and repaired files. It still wasn’t working until I right clicked the Epic Games Launcher Icon in the Start Menu and ran as administrator. Hopefully this helps!

Try exiting the epic games launcher and opening it again. The error occurs whether the user runs as admin or not.
Epic Games Launcher does not have a “repair” button, where are you finding this in the launcher?

The launcher installer has a repair button. Repairing the files, then running as admin did get it to work once, but now the problem is back.

I’m having the same issue (win7 64), but the UE editor still launches for me. It gives me the ‘unable to open’ message but then loads anyway. I get the same message with the launcher, but if I load the editor, then the launcher will open after.

Greetings.

I decided to do my own digging into this issue.

I refused to believe that I needed to install an old MS update to resolve this new error message, especially one that created a whole new set of concerns.

The following steps did in fact resolve the issue (on 4.26.1), however I recommend due diligence with this path.

Find a source for the dll ** Just don’t install anything! **
I found a rather obscure Youtuber who posted a link to his dll, but I needed to verify this was a good file.

Do the following so that you can feel confident with the file that you have found:

Download the kb4507456 update, but do not install.
Unpack the update with 7zip or some other similar application.
Inside, there is a Windows6.1-KB4507456-x64 cab archive. Unpack this.
Inside that directory there is a file called manifest.cix
This is an xml file and perfectly readable.
Open this file in a decent text editor.
Search for a reference to Api-ms-win-downlevel-kernel32-l2-1-0.dll
It will find the reference as well as showing a SHA1 hash, which is: b07a3f4403a93e87c787c22cc1196768cf837aa2
Use your favorite hash program that can verify SHA1.
After you have verified the authenticity your dll file, copy it to both:
\Epic Games\Launcher\Portal\Binaries\Win64
\Epic Games\UE_4.26\Engine\Binaries\Win64

It turns out that the editor is calling on this file as well as the launcher.

Have a good night and a pleasant tomorrow.

R

it seems that Epic Games’s staff need significant OPTIMIZATION
in 2021 Unreal engine lost dlls!!! this is unacceptable incompetence!!!

Worked for me.
(win7 64, UE 4.26.1)

This made Launcher to stop asking for .dll

(\Epic Games\Launcher\Portal\Binaries\Win64)

And copy .dll also to Engine folder made the rest.
(\Epic Games\UE_4.26\Engine\Binaries\Win64)

I did install the beloved telemetry update KB4507456 - becouse I am too dumb to do what **derezdev **propose.
Than I copy that .dll to both folders as you guys point. It work, but it is stupid fix for something that is shady as fukc. Any official comment on this thing yet?

And it was not only the Launcher as pointed - the same error appear in the Editor (4.26.1)

The same error comes in few variations in the editor - ShaderCompileWorker variant - is making the Editor practically UNUSABLE!
Because if I try to make a new material, or create or just edit some single settings in Niagara - every time - TWO windows of this thing pops out:

well it worked for a bit now anytime i on the win 7 box try and use 426 i get the error but then it runs
win ten wont get passed the NOT REPSONDING bit

trying to migrate to win ten is terrible

also get a real chromium programmer will ya

The DLL file “libcef. dll” is Chromium Embedded Framework (CEF) Dynamic Link Library and is used by many programs. This DLL file is digitally signed by Valve and is used by Steam and many other applications in their operation. … Press Windows + S, type “system information” in the dialogue box and open the application.

thats the dll thats crashing launcher all time as well

NO and they are censoring me saying stuff about 426 like , looks nice but wont run on my windows ten pc , and while i have win 7 and 426 running that api issue and libcef.dll keeps crashing an is signed by valve and yet steam runs perfectly on both boxes ROFL
i cant updaet the gt620 no more which is why i grabbed thsi slightly newer pc that came with windows ten
and a amd r230 2 gb card figuring the fx 6300 six core would be better hten a dual core 4 thread pc and its barely so cause ti wont use 3 of the logical processors in shader compiles even belnder dont liek it i had to use the LTS 2.83 OR use the debug graphiccard glitch script to sort for newer versions which tells me epic has no clue what is happenign and at min blender is aware of it
and remving my review that i cant use it cause your software wont work on my pc means guess what not able to review DUE TO TECHNICAL ISSUES there mister moderator
not on my end cause i have 424 and 425 installed and 426 on the win 7