Prgram cant cause api-ms-win-downlevel-kernal32 blah blah dll is missing

add to fact launcher wont work andive paid for stuff i can no longer use i want a full refund and will go elsewhere , DO YOU EVEN TEST c r a p anymore and i cant update launcher either

Having the exact same issue here as well. Was this caused by a recent update? I was messing around with Google Stadia last night and thought Stadia caused the issue.

Same error! Seeking solution! (I have no Google Stadia so unlikely this is the cause)

Got the same issue here \0/

ı got the same
Pls help
I can open but ı got error

Figured out a solution. Copy the file, api-ms-win-downlevel-kernel32-l2-1-0.dll, from your /Windows/System32/CompatTel folder to C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64.

I changed Api in api-ms-win-downlevel-kernel32-l2-1-0.dll to a lowercase “a”. I tried copying api-ms-win-downlevel-kernel32-l2-1-0.dll to the \Win32 folder and the error still occurs, it has to be in the \Win64 folder.

Not sure why a recent update would delete or modify the api-ms-win-downlevel-kernel32-l2-1-0.dll path.


to annoy you or me cause …

and that dir and file is not on my pc lol

and its a windows ten and 8.1 file i wont hav eit i have 7

but can confirm if you place the lowercase version of said file in there the error goes away

I dont have <api-ms-win-downlevel-kernel32-l2-1-0.dll> in the folders you suggest…
Win 7
Is this common problem this days? What happen? WHY?
Can I uninstall and install again the Launcher to fix the problem?

**WITHOUT this operation to mess up my Unreal Engine? **
On top of that I need to keep 4.19 so I dont want any mess just for the Launcher?

Running as administrator works, but it is not ideal solution.

I’m running Windows 7 x64 Ultimate. Try doing a search for “downlevel kernel32 l2” on your C: drive.

api-ms-win-downlevel-kernel32-l2-1-0.dll should show up under C:\Windows\System32\CompatTel

Can someone else confirm if api-ms-win-downlevel-kernel32-l2-1-0.dll is in the same directory on Windows 8.1 and Windows 10?

I’m running Windows 7 x64. When I first encountered this problem I uninstalled Epic Games Launcher and Epic Online Services. Reinstalled the launcher and the launcher will ask you to install Epic Online Services. Closed the launcher and reopened it and the error is still there.

Do a search for “downlevel kernel32 l2” on your C: drive.
api-ms-win-downlevel-kernel32-l2-1-0.dll should show up under C:\Windows\System32\CompatTel
Copy api-ms-win-downlevel-kernel32-l2-1-0.dll to C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64 and you should be all set.

If KB4507456 (or old KB2952664) is installed. It’s telemetry.
The problem is due to dbghelp.dll that uses api-ms-win-downlevel-kernel32-l2-1-0.dll (\Epic Games\Launcher\Engine\Binaries\ThirdParty\DbgHelp\dbghelp.dll).

Was anyome able to find a solution for Win7 with this? I’m having this issues since Friday. I can neither uninstall or do a repair install of the launcher, not even using the safe mode helps. I’ve started digging for .msi files in general and couldn’t find any. So I run WinDirStat and… turns out I barely have any .msi files on my system drive at all. As if they disappeared.
The problem started since I’ve updated my video driver. The driver asked for the SHA-2 updates of Windows itself, which I did. Then I’ve installed the most recent driver and uninstalled previous one. Rebooted the system, everything is fine, but Epic launcher started to throw this issue on me. Ofc their tech support instantly said that it’s not their problem and I should ask Microsoft… which replied that I should ask Epic for the correct installer, as the one their site is different (10.19.2) than the one I’m asked for (10.17) by my system. On unrelated note since I’ve updated the system, Sid Meyer’s Alpha Centauri graphics crashed, but that’s completely different story.
The worst part is that I can’t make a rollback to previous state system, because I have a save-state AFTER the updates of driver and the system itself…

Yeah, Microsoft snuck telemetry in a security-only update.
Is this issue exclusive to Windows 7? Do Windows 8.1/10 users have this issue?

I have the same issue on Windows 7 64-bit. This would supposedly be fixed by applying patch KB4507456 from Microsoft, but a download option is no longer available since it’s support life cycle has ended; all download links where removed during the last month. The worst part is that this is only required by the captcha checks during login; or at least I get no such message when for whatever reason the launcher deems me worthy of not being tortured by a dozen challenges to prove “I’m human”.

EDIT: I actually get the the message upon startup, but the captcha seems to be the only process that does not work and constantly barely blinks FAILED at the bottom of it’s area even if it’s properly answered.

Download link still works, Microsoft Update Catalog

Thank you!


Problem came with the last Epic Games Launcher update!
Verified on second machine:
Starts perfectly => Games Launcher Update => Restart => bam!..api-ms-win-downlevel-kernel32-l2-1-0.dll…in your face…

I can confirm that copying api-ms-win-downlevel-kernel32-l2-1-0.dll to C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64 works.

There is a bug in the current client!