Pressing Buttons causing touch input issues

I’m using touch input to orbit and move a camera around the center of my scene, that alla ppear to work fine, I’ve used in in projects before with no issue.

However, sometimes when I click a button on a widget it mis causing the camera to jump to a point in the scene, clicking anywhere else in the screen does not cause this.

There are multiple buttons each doing different things, generally setting a variable, nothing to do with the camera at all.

Would anybody have an idea of a pssible cause?

I’d be happy to show my BP but it’s rather large.

Many thanks.

Try setting your button’s Bool “IsFocusable” to false. You will find that in the details panels when you are editing your button in UMG.


Thanks for the response, sadly that hasn’t fixed it, however I’d like to know what “is focusable” does to buttons?

Think of it as having different things open on windows (chrome and ue4). You click between those giving the one you click on focus. Show me your BP and I’ll help you.

Figured out my problem!

It wasn’t to do with the buttons at all, I noticed in my touch input controls for rotating the camera my input axis would continue to sire after touch had been released.

Connecting the “released” from my “input action finger 1” to the close gate coming from “input axis finger 1” solved the issue.

I presume clicking the buttons was triggering the gate again and the finger axis was now far away from the last released position causing the camera to jump. I’ve no idea why as I have a swipe threshold that presumably should prevent this but either way it seems the cause was from not closing the gate when the input was no longer needed.

Thanks for the help Debaucher. I solved the issue (noted below) but many thanks for offering help. I learnt a little more.