Preloading Sequencer audio track asset

Hi.
I have a level sequencer with several short audio tracks. When I build and launch the final application (Windows 64 bit platform) I am getting the following errors/warnings:

LogAudio: Error: Soundwave ‘SoundWave
/Game/sounds/BirdsDemo/two.Two’ was
not loaded when it should have been,
forcing a sync load. Warning:
Reloading inlined bulk data directly
from disk, this is detrimental to
loading performance. Filename:
‘…/…/…/AnimTest/Content/sounds/BirdsDemo/two.uexp’.

I understand that this has to do with the fact that the engine is trying load the audio stream from the file,which incures some latency.
Also,in my use case I don’t keep sequencer instance in the level ,but load it via BP by creating sequencer player in runtime (That’s because the user decides what to play). I was under impression that loading the sequencer
How can I preload the audio files used by those sound tracks of the loaded sequencer?

Did you find any solution to this?

You should ask the questions in the comments area,not in the answers :wink: Yes I did. You must define it as an asset which should be preloaded by UE4. Read about it in the docs.

You should (or maybe, must) share your solution to the community if you find it. Not everything is asking.

I’m running into this issue and I’m not sure how to solve it. Can you explain your fix?

SasMaster asks a question to help find a solution to his own problem, finds the solution, Raz comes in and has same problem, asks for SasMaster to share solution. SasMaster says go read the docs.

Expecting help and not paying it forward. Not even a link to these docs that are mentioned. Completely self-involved.

In my case, setting the audio file (wav) to Prime on Load worked to remove the errors that the sequencer was throwing. Here is the doc that describes it for other potential solutions you may need.

See how easy that was SasMaster?

1 Like