PP Material through matinee

I’ve done this a hundred times in UDK but I can’t figure it out in UE4.

How do I take control of a material instance that’s used as a blendable on a Post Process volume using matinee?

I want water to drip off my screen and I want to be able to control blending it out over time in matinee.

I can’t just swap between pp_volumes because that cheapens the wipe effect as I have a lot of controls to exactly control pan speeds and mask wipes…etc.

I found a materialinstanceactor I can place, but all I can do is assign an object to it, not a material.

I tried with both that and the PP_Volume actors selected when making a group

Direct manipulation of the material instance works fine for the blendable. I just can’t get matinee to see it.

Please help.

Hey Hitpawz -

You will have to set this up using Matinee and a Level Blueprint. Create an Event Track in Matinee and Choose at what point in your timeline you want the change to happen then call a reference of the matinee actor in your level blueprint. You will then pull off of the event output pin from the Referenced Matinee actor and change your MIC information in the Blueprint Event Graph. I would also recommend the use of a Material Parameter Collection which will eliminate the need to make direct material changes and just smoothly transition variables.

Thank You

Eric Ketchum

This is proving to be quite difficult. I can’t get the Set Scalar Parameter Value to work at all. It doesn’t pop up on any contextual menus and it’s inaccessible from the library. In fact, everything under rendering/materials is hidden and inaccessible.

I couldn’t get the PP volume or the material instance or the parameter collection to be recognized anywhere in the level blueprint at all. So I added the material to a sphere object I plan to hide so I could reference that.

The material is properly using the parameter collection. The mat instance is not showing any parameters since the material is using the collection.

I can pull out a Set Scalar Parameter Value node, but it’s not a collection, it’s referencing self or an object/material.

If you look at this screen…I simply cannot get the blueprint to drop that collection node out into the graph. The tappy chicken example and the docs just say “use this node” but I can’t.

What do I have to have selected or setup special to get this particular node to work?

Ok I got it working, I just restarted the editor and I was able to place Set Scalar Parameter Value from the non-contextual drop down. Not sure what the problem was, just a glitch I guess.

How do you get a reference to the MIC being used by the blendable on a camera though? Creating a dyanmic instance in blueprint doesn’t affect the camera’s referenced MIC.

You don’t reference a MIC and in fact, you don’t even use a MIC. You use a material parameter collection that’s added to your base material. With that, you don’t actually need to create a MIC at all since the collection will control all of your parameter values. I made a video on how to do it.

Awesome, thanks man, super helpful

This new method works, but it’s not really ideal for complex animations of variables and settings. With this new method it’s not possible to scrub and preview the result in real-time in the viewport. So it becomes very time consuming to make tweaks / PIE back and forth until it looks good. I wish the old method was still available using Material Instances, especially when dealing with Post Process Materials.