Download

Potential Bug in 4.25 Converting BP to C++, or am I did I forget something?

Hi Guys,

I just started a new 4.25 project today and spent a better part of 3 hours chasing my tail.

Within the project, I created a new C++ class, created a new folder directory, and activated the public option (this is what caused this in hindsight). After waiting for UE4 to compile, I was greeted with an error stating that I would need to compile UE4 to have the new class show up, but the compile button was missing. Having danced this tango in the past a few times, I proceeded to close down UE4, generate the VS project, and build the project from the <.sln> file. However, I continued to have some issues as VS would throw a few errors when trying to build the file: C1083 and MSB3073 with code 6.

OK, so I proceeded down the rabbit hole of reddit threads and such until I came across https://www.reddit.com/r/unrealengine/comments/gphjjj/unable_to_compile_c_project_425/ where people have been recommending using an older version of VS. Since I only have the community version on this computer and it doesnt appear Microsoft allows access to prior releases of Community versions. So I deleted VS 2019 from my computer and decided to try this using VS 2017. Same problems as 2019. After creating the project from scratch again, I tried it without clicking on public for the header. This seems to have worked as suspected.

Is this normal or did I do something wrong?

Ya, further testing looks like that UE is not automatically creating the full paths for newly created classes.

I added a subfolder to put the character class into named classes, and if I go into the .h and add the “Characters/ …” to the include, it works. Shouldnt unreal automatically take care of this?