Download

Post Processing Quality of 0 or 1 VASTLY DIFFERENT than 2 or 3 as far as lighting.

My game is pretty simple as far as lighting goes. Or so I thought. I’ve just got a flashlight that the player has, and then I have a Moonlight that moves across the sky and a skylight that just provides ambient lighting in the level. However, I’ve discovered that with my Post Processing Quality settings set to either 0 or 1, the lighting is pretty much non-existent (except for the player’s flashlight). Post Processing Quality levels of 2 and 3, show the level just fine. Here’s a visual of what I’m talking about:

Post Processing Quality 0-1:

And this is Post Processing Quality 2-3:
…attempting to attach another image, but keep getting database errors… will keep trying…]

Anyway, I’ve been just adjusting my blueprints to use PPQ 2 for my Low, Medium and High settings, and using PPQ 3 for my ‘EPIC’ settings. The problem is that some computers don’t apparently support this at all… Regardless of the quality settings I get the darkened image that you see above for the 0-1 settings instead of the lighter settings that I’m still unable to upload after five tries even with renaming, retaking and totally starting the message over… (I’m still working on that, though. Just need to get this posted.)

If anyone else has seen what I’m talking about and knows how I can go about fixing it, PLEASE let me know! This is a show stopper for me at the moment until I can get this resolved or find a workaround for it.

I have to leave at the moment, but I’ll continue to try to get the screenshot of what it SHOULD look like in a little while after I get back.

-Marc

Okay… It’s still not letting me upload any of the 4 captures I have of the second quality setting… I can upload any other image, but not any of the ones I actually NEED! This is annoying. It’s happened before and I have no idea why. I’ll try again later, or just make a video to show what I’m talking about. (If anyone has a fix for these “Database Errors” that keep coming from the page when you try to upload an image, I’d LOVE to know about it, because this has happened before in this type of situation. is it because it thinks that it’s a duplicate image? It always seems to happen when I’m trying to show differences on similar images.)

EDIT: And for some reason, after I posted this, an “attached image” showed up with the post… And it’s my OLD image from the last post. Not even the new image I’ve been trying to upload. VERY annoyed, and now I’m late for my appointment. I guess that’s why things are being difficult. That’s when they always are.

Okay, it must be a “Similar” thing… I just re-screenshotted my “paint” image and captured a lot more of the image. But, regardless, this is what the scene above is SUPPOSED to look like. This is with a Post Processing Quality of either 2 or 3.

Again, it doesn’t matter if I set this manually or not. Even on some computers with this set to 2 or 3, it looks like the image in the original post. (i.e. My son’s Acer laptop gives me the bottom image. My daughter’s iMac (running Windows) gives me the top image.)

I’m still working on game logic, but if I cannot get this resolved, it’s a show-stopper.

I’m looking for ANY suggestions!

Thanks!

So if you look at this page

You can see what each level of sg.PostProcessQuality does with the various rendering tweaks underneath.

Play around with those other console commands to get to a level you’d think is respectable.

In my experience, if you’re trying to improve the framerate on lower end machines, your best options are removing anti aliasing, shadow quality, ambient occlusion quality and (for intel HD integrated rubbish) changing the resolution scale.

To be clear, this is my widget code for setting the quality.

7c61b427b8df7d5d49d5561291b6d2f3956f8296.png

On most machines, everything works great. But on some systems, every quality level looks like the darkened image above. It doesn’t seem to matter what I change for my settings, though I can REPRODUCE it on my current machine by setting the Post Processing Quality level to either 0 or 1. So, I don’t think it’s necessarily a problem with the Post Processing Quality’s underlying settings, but something that is not supported within those settings on certain systems that I need to find another way of doing. I just don’t know what it might be. It’s affecting both the skylight that’s giving me global ambient illumination and the directional light that is casting my shadows as the moon moves across the sky.