Download

Possible solution for packaging fails for iOS

I’ve been having issues getting 4.4 to package and deploy to my iPhone for the last few hours. After seeing lots of other people having issues and no good answers, I thought I’d post what I found seems to work (for now at least).

In …Projects/<projname>/Build/IOS I had 2 .plist files for some reason. One named <projname-info> and one named info. No idea where these come from, but I had noticed that when editing the Project settings in editor that info.plist was the one that got checked out. So, on a hunch I deleted the other one and tried packaging again and it worked.

Not sure where that came from and not sure why it was an issue, but maybe that will help someone else.

Good catch. The code for writing out the Info.plist got change for 4.4, but it looks like the code which looks for the Info.plist is looking for Game-Info.plist first and then Info.plist. Deleting the Game-Info.plist is the correct workaround for this problem until I can put in a fix.

-Pete

Good afternoon. You couldn’t write in more detail as you removed the problem. Unfortunately I couldn’t understand as you solved a problem. Thanks in advance for the response.

Sorry, Ivanov not sure what you’re asking. The solution for me was to simply delete the extra .plist file found in my project’s /Build/IOS folder. If you open the .plist file in wordpad, you should be able to see if it has your app’s BundleID or a generic one from UE4. You’d have to check your Apple dev account to know what yours should be. Is that what you’re asking?

@Psauer, another issue I noticed is that certain files seem to need to be writable, but the editor doesn’t tell you this. I keep getting the failure almost immediately if this is the case. Since I don’t know what needs to be checked out I just check out my entire project and it runs fine. Would be nice to know what those files are and even nicer to have UE4 tell me it needs them before trying to do anything.

In 4.4 you can enter all the infos in the editor under project settings -> ios, wich is very handy. No more need to manually edit the plist file. For projects converted from 4.x to 4.4 , you just need to delete the GameName-Info.plist and re-enter game name and bundle identifier inside the editor.

Good afternoon. To a regret it doesn’t help me!!! I tried everything as there it is written. But I can something not so I do here a photo

The bundle identifier is wrong. It is the inverse url string, that you specifiy when generating the provisioning profiles in the Apple Developer portal. Like com.myname.mygame .
And you need to put your provisioning profile (*.mobileprovision) in the Build/IOS folder aswell.

hi, HEGI
i have put the .mobileprovision in the Build/IOS folder, also set the info.plist bundle identifier to com.epicgames.myprojectname.
i created a first person template project to test, it can launch on my device.
but when i run my project, that copy from the windows,
LogPlayLevel:Display: env: Check dependencies
LogPlayLevel:Display: env: Code Sign error: Automatic provisioning profile selection unavailable: A bundle identifier is required for automatic provisioning profile selection. Either enter a bundle identifier in the Info.plist, or select a provisioning profile to use in the build settings.
LogPlayLevel:Display: env: CodeSign error: code signing is required for product type ‘Application’ in SDK ‘iOS 8.0’