Download

Possible bug with Mouse X/Y events? Or I just don't know how they work

I recorded a video of this.
https://youtube.com/watch?v=FJNMPim7Dtc
I have a camera rotation system here that rotates the camera when I hold middle mouse button down and move it along x axis. But when I press and release any other mouse button while still holding down MMB it stops updating axis value. It then only works if I hold any other mouse button down alongside MMB.
Note that I only release MMB in the very end of the video.

Any ideas?

Hello SinineSiil,

I could not reproduce this issue on our end. However, I tested this in the 4.8.2 version of the engine. I have also included my setup below. If you are using 4.8.2 and it is a project that has been upgraded from an older version of the engine you can try using the “Refresh all Nodes” feature. This can be found by opening your blueprint and going to file > Refresh all nodes. I hope that this information helps.

My test setup:

I used a gate that opens and runs a loop with a .01 delay when I press the middle mouse button. This loop will continue to print out the mouse position until I release the button. I tried holding the middle mouse button and then left and/or right clicking, however the release execution only fired off when I actually released the middle mouse button.

ac3de09d2077faf550ac99adab9552a4f66d7433.png

Make it a great day

Edit: Fixed attachment

Thanks for a response Rudy

That attachment doesn’t seem to exist…
I tried this setup in new 4.8.2 topdown example project:
2015-07-24_01-29-45.png
And it resulted in same thing. Everything worked til I pressed another mouse button. Then it only updated when I also held another button down.

Edit: It works fine in blank project though…

Why doesn’t this work in Top Down example without holding down mouse buttons?
2015-08-10_01-30-13.png

Edit: It also doesn’t work in Puzzle example. I guess this issue happens in projects that use mouse cursor to interact with stuff.

I discovered that axis values won’t update without holding mouse buttons if input mode is anything other than "Game Only. It doesn’t work when it’s on “UIonly” or “Game and UI” mode.
I need to use Game and UI mode since interacting with UI is big part of the game I’m trying to do.

What should I do?

There needs to be “Get Input Mode” node so I could find the source of this issue easier.