[Portait Mode]

1st of all hi!

-Is ue4 able for proper Portrait mode?

-Can it be set on portait with Constrain Aspect Ratio?

-Can the custom Ratio be seen on EDITOR like it should? ( i know i can pilot cam to view it ) :slight_smile:

-Can you Set something in BP like in CHICKEN GAME , But in Perspective Mode?

-How will the widgets get different size on Portait mode?

-MORE or less will the UE4 be able to set a proper PORTRAIT mode with a CONSTRAIN AR to be used for mobile game in the future??


I’d like to know this too

Edit -> Editor Preferences ->Level Editor -> Viewports -> Aspect Ratio Axis Contraint -> Maintain Y-Axis FOV

It should make fine aspect ratio for portait mode in editor.

Can this be set on mobiles? Constrain Y axis

Change aspect ratio on main camera actor.

Cant see any difference when changing it… Also while i was testing the Aspect Ratio (0.5625) of my Player Camera, i saw Black Borders on some test devices. Can you Help?
I saw you ve done great job on Chassing robers congrats!

check in your project settings

You can lock a game into portrait mode and the camera should scale automatically assuming you’re using the right scaling type (eg 16:9 in ortho would be 0.5625 ratio). There will be borders if your orientation isn’t set properly in the settings, as shown in the above screen capture.

Widgets auto-scale but you may have to create the scale yourself for special resolutions. It’s in the settings somewhere, perhaps someone could point you to it. As an example: if you design your widgets as 720x1280 then on a 720x1280 phone the ratio would be 1 on the scale. But on a 1080x1920 it would be 1.5 on the scale (1920 / 1280). Same thing applies when down scaling. That’s what I did – setup custom scales and used a fixed 720x1280 widget size rather than the prefixed iPhone4S, HTC One, and so on.

So to sum… In need to have ‘landscape’ orientation and not ‘portrait’??? And if I put aspect ratio on 0.5625… I still get black borders can someone plz the settings for this? Am using perspective camera

oh non, you need portrait in your project settings and a camera with 0.5625 (instead of 1.77XXX)

it can be only your preview that have bad resolution preference
you can preview your game in a ratio of 480x854

(at the bottom “advanced settings”)

I have the same problem, I tried with landscape on/off and it still shows borders on UE4 mobile simulation

Just up until 4.25 there’s a bug when "Show Launch Screen " is enabled. Disabling it will result in full aspect ratio. :slight_smile:

Nothing better than when links to the official documentation result in 404’s.

1 Like

--------> WTF Is? Camera Aspect Ratio Nodes in Unreal Engine 4 ( UE4 ) - YouTube

Thank you for that.