Download

Point lights overlap x errors?

So I’m wanting to make my horror game with some realistic lighting but the issue is I’m getting x errors on them saying " it’s overlapping " is this a very common thing that happens like? is there anyway to fix this without having to remove all the lights in a room. My room has 1 point light and each room is class as one room for each building if you know what I mean. e.g this hotel I’m building has 2 rooms with 1 point light in each room but when I had 5 rooms next to each other I get an x error about ab point light overlapping…

You need to make sure that when using stationary lights that no more than 4 overlap an area.

No more than 4 shadow casting Stationary lights, that’s the important part. You can have any number of unshadowed Stationary lights overlapping, provided you want to pay for the light cost.

If you aren’t going to cast shadows then you might as well use movable lights, it would be the same thing

I can imagine situations where I’d 'like a light to contribute to GI even though it’s not casting shadow, so it’s not the same.

The way I understand it, objects can only receive light from 4 light sources with GI. If you have too many lights overlapping, the engine will pick lights as victims to be converted into dynamic lights.

If the conversion takes place, your lighting quality and your performance will go down a lot. Plus they will not be part of the bake, so no indirect lighting, no bounce light, no soft shadows etc. If all your lights are baked, the lighting is essentially free in terms of performance. But having stationary or dynamic lights are always going to eat away at performance.

So the big question is why you need to many lights so close to each other?

It could be that your intensity values are not high enough. So maybe you are trying to produce more brightness by adding more lights to compensate.

It could be that you do not understand the attenuation radius setting. Light has a fall-off, to travel twice as far it needs to be 4 times more intense. You need to tweak your attenuation radius so that it is no bigger than the threshold for where you light falls off to nothing. So your lights might be overlapping because you have a large attenuation radius, even though in reality none of the light will ever travel that far.

It could be that you do not understand exposure. If you have low light conditions you need to reduce the exposure value rather than adding more lights. You can do this in the Exposure section of the Post-processing volume.

It could be that you do not understand that your base colour values also affect brightness. If your materials are too dark, they will produce less bounce light and the whole scene will look darker than it should.

If it is a night time scene, you can still have a directional light coming in through the windows, but you would change the colour so it is white/blue and a lot lower intensity like it was fake moonlight rather than the sun. That might help. You can see an example of this in the Soul City environment available for free from the Launcher. You might have to add light mass portals to boost the effect.

It might also help to use spotlights instead of point lights. A point light is like having 6 spotlights joined together, two lights pointing in opposite direction for each axis.
hope that helps