Download

Point Cloud Plugin

Hi! I’m having an issue with rendering views of LiDAR data from camera actors. The density of the cloud and the size of the points are based only on the position of the main viewport camera. As I fly around, the point cloud data changes appearance in the views from the other cameras. (the attached images show the same camera actor output with my main camera far away and close by).

I see some stuff a couple pages back (in June) about an error that sounds pretty similar specific to the Cine Camera, but this is with just a regular Camera Actor. Not sure if it’s the same issue.

Is this intended behavior? Am I just missing something? Is there a workaround? Has this been addressed in the latest engine update (or is there a way to grab the latest plugin without having to upgrade engine versions)?

Thanks!

Hi there.

The issue does sound like the one mentioned in the past, however, we have fixed it in 4.25.2. If you run a newer version and still experience this issue, it may be caused by something else.
Let me know.

I’m on 4.25.3. :confused: I’ve got 6 different camera actors in the world that are rendering out to jpg. Need to have the same simulation running from multiple viewpoints. But the lidar data looks bigger and sparser the further we get from the ‘main’ viewpoint. :confused:

I think this may be a different scenario than what was described previously. Is there any way to simply force the lidar data to always draw at the highest-quality LOD regardless of camera position?

Ah, what you describe may also be caused by viewport prioritization. By default, we drop to the lowest LOD on inactive viewports to maximize performance in the active one. This can be disabled in Project Settings > LiDAR Point Cloud > Prioritize Active Viewport.

See if that helps.

Note that disabling the option will result in the point budget being split between all viewports and you may need to compensate by increasing it (cvar r.LidarPointBudget x)

I had tried the ‘priotize active viewport’ with no luck yesterday. Bumping up the point budget definitely seems to have an impact. The density now stays the same regardless of my primary viewport’s distance.

The size of the particles still seems to change somewhat as the main viewport gets closer. And when the points are outside the main viewport frustum, everything still goes nuts (point density becomes minimal, and point sizes go from miniscule to huge, depending on how/where my main camera is positioned).

While it would be ideal to get this resolved as well, what I’ve got is certainly sufficient for the demo we are trying to produce. Thank you so much for your help!!

Hi there,
I am having issues rendering videos from a LiDAR point cloud in 4.26. It used to work quite nicely in 4.24, but I updated to 4.26 for the “unlimited” point cloud size.
Now the camera cuts look great in the viewport, but once I render a video the points look bloated and they flicker on and off as tiles.​​​​​ (see screenshot). After reading most of this thread I already tried changing settings such as point budget in output log but to no effect.

Any ideas what I might be doing wrong?

Thanks a lot for your help!

Hi @NVMUC

Thanks for the report!

A few questions:

  • Is this an upgraded project or a fresh one?
  • If an upgrade, can you reproduce this on a blank 4.26 project as well?
  • You mentioned you have changed the budget - what is your setting?
  • Did you change any other cvar values?
  • Could you describe your scene setup? How do you record the takes?
  • What is your CPU/GPU?

Feel free to send me a private message if you’d rather not share that publicly

Hello,
I have a question: is it possible to import scan setups rather than entire point clouds? My cloud is properly registered and exported as e57 “per scan station”. When I import them into UE 4.26 the scans are not aligned properly. I thought that changing their location to 0,0,0 will solve the problem but this did not help.

Hi @ziutek27

By default, all assets are being centered on import to avoid precision loss.
The easiest way to relatively align several clouds is to select them in the Content Browser > right-click > Align

Let me know if that helps

Thank you phoboz. Your advice completely solved my problem.

Hey, just wondering if there’s any update on Niagara integration? If not, does anyone have any ideas how to get point clouds in to Niagara without converting to a mesh?

Particle systems are such a nice way to render point clouds, and I know a few other people who are also hoping for this feature!

Hi there.
There are no immediate plans for the Lidar <> Niagara integration.

Try to convert the point cloud into a CSV, which you can import as a datatable. Then you should be able to generate the points with Niagara

I’m not sure if this subject is still active, so here goes. I’m trying to visualize lidar points from a grpc server that pumps in points every frame, i’ve hooked up the data source in blueprints to call SetData() with the new TArray of points. In editor mode everything works fine, however in the game debug mode, or packaged build, it will crash every now and then. I’ve attached the stack below, maybe i’m using the class wrongly. Thanks in advance for any guidance on this.

Hi, and thanks for the report - will investigate!
Do you know which line number it crashes at?
Could you send us the log file (you can do it over the private message)?

Hello, :wave:
I am using Unreal Engine 4.26.2, and trying to create a scene based on importing point-clouds (ASCII File).
I am working on a mac computer. and using the built in LIDAR plugin.

Everything works pretty well, but when im trying to render it as a video, the amount of the pointclouds, their density, and their size changes and the output mp.4 does not look like what i saw in the original scene in UE4.
(Screen Shot Example Attached)

Some tutorials suggest to pump up the point budget. but for some reason there is no point budget option in my UE4. Its like that function dosent exsits in my interface…

Can anyone tell me what to do, to make it right? I’m really lost with this one.

You can access point cloud budget with console. Look for the commands. This option is seen on early videos but in newer versions it is removed from the interface.