Plugin wont build

I have a plugin that I built in a previous version of UE4 (4.6) and I have updated the engine since then, but I cannot get UnrealBuildTool to actually build the plugin now. I have rebuilt project files, completely recompiled the engine, and even checked ‘UE4EditorModuleRulesSourceFiles’ to make sure the folder for my plugin is being included, which they are, but for some reason it just gets skipped over when building the game/editor.

I’m completely out of ideas at this point, since this worked before and should at least try to compile the plugin even if there are issues with it. Is there a way to force compile a specific plugin/module or something I can check to see why its not compiling my plugin?

Found the answer myself! Turns out since the plugin was set to “EnabledByDefault” : false, UBT was skipping over it, however the project that was set to load when the editor opens requires that plugin, so it would fail to load the editor. By switching EnabledByDefault to true, UBT finally built the plugin and allowed me to load my project.

I’m not sure what the reasoning is behind skipping the build process for a plugin if its set to EnabledByDefault:false, but it seems like plugins should be build regardless of whether or not they are enabled by default in projects, and potentially some other var in the uplugin file could skip building if thats needed.

Wow, this worked for me as well! I agree it is not desirable behavior.