Download

[Plugin] Runtime Mesh Loader

Any Idea if you can extend this to alembic ABC files ?

I’m able to run it in the editor, but getting assertion crash during runtime.

Open RuntimeMeshLoader.uplugin and change “Type” to “Runtime”.

What’s the usage license? Are we allowed to modify and use this without any limitations in our projects?

the license is specified in the GitHub repository. It’s the MIT license (open source) and here’s the URL to the LICENSE file if you need it: RuntimeMeshLoader/LICENSE at master · GameInstitute/RuntimeMeshLoader · GitHub

@serioussam909 @Rusel2050 I’m new to Unreal and I tried this plugin, but it’s different with ones in windows model builder, Can anybody give me help on this? The following is my usage.
1.Create a actor with proceduralmesh component.
2.bp.png is my BP
3.rightshow.png display the original obj model
4.Wrongshow.png is displayed by This plugin.
I’ve no idea why the shape is in distortion and texture is gone.

For anyone downloading this plugin check out here: Comparing GameInstitute:master...Branden0Marais:patch-1 · GameInstitute/RuntimeMeshLoader · GitHub . Its a fix for a error on plugin compile.

I’ve tried this for version 4.21.1 and 4.2.1 but I get a incompatible version

It’s in the right location I think

C:\Program Files\Epic Games\UE_4.2\Engine\Plugins
and
C:\Program Files\Epic Games\UE_4.21\Engine\Plugins

can anyone explain what I did wrong or what version this is actually for

Thanks in advance

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_167431_1561516148402_49”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

To understand what I was doing I made a short video this including making a plugin forlder for the projects directly and still didn’t work

https://www.youtube.com/watch?v=24PV6S8KffE

I am currently attempting to import an fbx file with this plugin. Obj files worked perfectly. However, the fbx will not import. I am using loadmesh then break returned data, and when I break the return data and read the elements, it reads as unsuccessful.

I’m attemp to get the model’s material.Is there any way to achieve it?

Hey, nice thing to have :slight_smile:
Is it possible to make a git commit to your project, that you can review and maybe integrate? Saying that because I had to modify your plugin to implement Android support : i did a build of Assimp for Android arm7va, and added support to your plugin. Might be nice to update it with the latest version of assimp for windows and mac, too, if that’s not already the case.

Hi, I’m planning to use this plugin for an android targeted project. Can you please tell if this plugin now supports Android. If not, what changes did you do to support android?

Hi is this plugin working for skeletal meshes? I am trying to load a skeletal mesh fbx at runtime but it is not importing the skeleton for the mesh? Can anyone please help?

Hello @GameInstitutes, thank you for this plug-in. I would like to know if an unreal 4 v24 version is in the works. Or is there a simple way I can migrate the plug in to be compatible with v24.

Thank you,
Joey

Is there any news about this? I am very new in ue4 and C++ and I dont know wether I cannot compile this plugin because i did something wrong or if it is just an incompatibility with my ue4 version 4.24 … I really need to have this plugin :frowning:

Thanks for your help

This plugin seems nice but please can you create an example scene or at least some better explanations on how to use it?
I followed the readme file, but still don’t know how to check if I’ve done something wrong because it doesn’t show anywhere in my project…

Hey, do you guys finally success to do it for android? I’m compile the Assimp library to Android, and connect the .so file with plugin, everything is fine, but i can not open the 3D file, any idea about that?

Hi, I managed to make the plugin work on UE4.25 just by switching the projects Default Build Settings (In the EditorTarget.cs) from V2 to V1 and by adding the lines specified here https://github.com/GameInstitute/Run…Marais:patch-1 . I also had problems with the plugin MagicLeap in “Break Returned Data” so I deactivated it as well.

I am also having an issue so I’d be grateful if anyone could help me :
I am trying to load a mesh made of two subcomponents. The problem is, the Procedural mesh component in which I store the data will not let me see one of the two components (I think it only keeps the last one) and I can’t figure out why. I checked a couple things that may help us find an answer :

  • The Load Meshe’s “NumMeshes” always returns 0, whatever the actual number of components is (can be one, but still 0).
  • The “Mesh Info” actually returns a size 2 array, which is great.
  • The Length of the array returned by “Get Material Slot Names” from the procedural Mesh Component is 0
  • But, In the editor, at runtime I can see that the material slots are actually there, and if I apply a material to them, the “Get Materials” has size 2 (only one is visible still)
  • “Is Mesh Section Visible” returns true for both sections

And that is quite about what I’ve got until now.

Thanks for your help !

It seems as if the repository was abandoned.
I did a fork of it and fixed (hopefully) all of the bugs and also included a texture loader into it.

Link to my fork: https://github.com/Chrizey91/RuntimeMeshLoader

Link to my forum post explaining it: https://forums.unrealengine.com/t/free-open-source-plugin-for-loading-meshes-and-textures-during-runtime/228445

1 Like