Download

[Plugin] Leap Motion - Event Driven

Greetings all.

I’m working on a Leap Motion project where as much game logic as possible is being kept in C++. The documentation on github implies that the same setup logic in blueprint should be applicable in C++, but I’ve hit several stumbling blocks trying to do so. I’d just like to check that I’m not missing anything obvious in my approach.

First off, when using the in engine plugin included with 4.12.5, trying to access any of the functions of the classes in the AnimBody folder results in LNK2019 errors. After some digging, I realized this was because said classes were all missing the LEAPMOTION_API specifier. Adding the specifier back in resolved the LNK2019 errors, but I’ve had problems instantiating them in C++. I’ve tried CreateDefaultSubobject and NewObject to make AnimHand objects, but the internal AnimFingers/AnimBones always end up null. Is this set of classes just not setup to work in C++? Or am I doing something wrong?

Also, I wanted to make use of the LeapEventInterface, but they’re all specified as BlueprintImplementableEvents. This means I can’t directly inherit the class and provide a C++ implementation, correct? Or am I missing something?

Hey there getnamo, thanks very much for the hard work you’ve put into this plugin. Echoing what some others have posted, I have had similar collision issues following your Jenga tutorial with the FloatingHandsCharacter - I can’t seem to detect on hit events in mesh to pick up’s blueprint, where we check if it implements the interface - I made this work with a block component in the FloatingHandsCharacter BP (made a “stick” and got attaching a pickup cube to the “stick” to work by toggling grab with a key press) - this is also for a university project, I’ve tried setting the collision in the meshes (LeftHandMesh and RightHandMesh) in LeapRiggedEchoHandsActor to PhysicsActor but that doesn’t work. The hands are grabbing but they are not being detected as touching the cube. If anyone has a solution to this it would be greatly appreciated! :smiley:

Please help me.
A few days of suffering…

I try to attach the object into the socket.

https://answers.unrealengine.com/questions/486542/how-can-i-attach-a-object-to-socket.html

Please check your question for the answer, I’ve added a reply.

This is a good catch, they should be BlueprintNativeEvent instead, which will allow your interface object respond implement the events in e.g. this format:


virtual void LeapRightHandMoved_Implementation(ULeapHand* Hand) override;

for each event.

I’ve added this as a github issue for now with a branch; will test this on the next plugin pass.

Check your character settings, they may be overriding the ability of your meshes to collide. Also keep in mind that the jenga video is just one example of how to get something like that working and should not be considered the definite way.

I’ve looked into this and the transition to body state in the next dev release should enable replication correctly. Stay tuned :slight_smile:

Thanks for the reply getnamo! I’ve figured out a work around! I instead placed the blueprints inside LeapRiggedEchoHands, the child actor for LeapHands iirc (I’ll check this tommorow to confirm but I thought I’d writed quickly for now). Once I did that I got it working. So for anyone who has the same problem, place it in the child actor and cast your grab variable from the your character to that bp to check if grabbing. I’ll post a screenshot of my bp later. Apologies if I explained incorrectly here. :smiley:

EDIT: So just to clarify, instead of placing your bp functions and nodes such as pickupIfEmpty inside the BP_FloatingHands you move it to LeapRiggedEchoHands actor bp. I know there are better ways to do these things but I didn’t have a lot of time :stuck_out_tongue:
Step 1.png

Thank you!

But still i can’t attach a phone to socket.

I’ve added a photo to the thread .

Please check again.

https://answers.unrealengine.com/que...to-socket.html

Thank you!

But still i can’t attach a phone to socket.

I’ve added a photo to the thread .

Please check again.

https://answers.unrealengine.com/que...to-socket.html

Thanks for the reply! I’d actually poked around the plugin code myself and came to a similar conclusion.

One thing to note is that simply making all the functions BlueprintNativeEvents means that any C++ classes that extend ILeapEventInterface must explicitly provide definitions for all the BlueprintNativeEvents in the interface. For me this means seventeen empty stub functions, for the five or so events I actually care about. Could be worse, but still pretty messy to deal with. Trying to put stub definitions inside of the interface doesn’t work, as this results in a compiler error about being unable to instantiate abstract classes. I assume this is unreal trying to enforce interfaces as function declaration only.

I was thinking about other solutions, but I couldn’t think of any that felt strictly ‘better’. There’s splitting up the LeapEventInterface into several smaller interfaces (hand, finger, gesture, passthrough?), but that’d require some significant changes in LeapController, and it could be disruptive for existing projects. On the plus side, it could result in fewer extraneous event calls, depending on how its implemented. Another possibility would be to use the regular C++ virtual function for native implementation, as that can have an overridable implementation in the interface, and then wrap that and the BlueprintImplementable function in a function:

.h


UFUNCTION(BlueprintNativeEvent, Category = "Leap Interface Event")
	void OnLeapHandMoved(ULeapHand* hand);
	virtual void OnLeapHandMoved_Native(ULeapHand* hand);
	void LeapHandMoved_Exec(ULeapHand* hand)

.cpp


void OnLeapHandMoved_Native(ULeapHand* hand) {
	//stub function so implementation is optional};

void LeapHandMoved_Exec(ULeapHand* hand) {
	OnLeapHandMoved_Native(hand);
	ILeapEventInterface::Execute_OnLeapHandMoved(this, hand);//not sure if this would work, havent tested
}

But then that removes the possibility of doing things like defining an event in C++ and then overriding it in a blueprint child.

I had the plugin working but now with a new project in 4.11.2 I am getting this error

“Missing or incompatible modules in LeapMotion plugin”

Any ideas what I am doing wrong?

EDIT - Nevermind I guess the plugin got built in the engine? Or maybe I put it in there. Not sure.

Has anyone had issues in 4.13? It seems to be working fine…?

I think stubs is the correct way to go for now, it might be a bit annoying but it’s harmless. May not be very clean, but being explicit is very C++ :stuck_out_tongue:

Yep since 4.11 the community plugin is the official one and is now included in each engine release.

I’m looking for information on how to remap the coordinate system of the Orion Hands.
Looking for where I can control/modify position relative to screen space.

Thank you.

The plugin automatically remaps the coordinate system from Leap space to UE space.

That said, if you use the convenience hands you can modify the coordinate by just parenting a scene node; if you use blueprint custom or C++ you can modify the output you receive from the plugin by multiplying the output by a transform. Optionally you can modify this file: leap-ue4/LeapInterfaceUtility.cpp at master · getnamo/leap-ue4 · GitHub to change the coordinate system transform globally for all output from the plugin.

Thanks for the reply @getnamo!

I’ll give it a try and let you know how it goes.
( because I KNOW you’re on the edge of your seat )
:slight_smile:

Hi,
Thank you for your work.
I was wondering if there’s any way to animate my own rigged hands using the location and rotation data provided by the leap plugin.
Has anyone been able to do this using blueprints? I would appreciate the help.

Thanks !

Hi Catonice,

Could you explain your fix a bit more in detail?
If possible maybe show your complete blueprint? Can’t seem to get the floating hands to work…

Thanks !

This is done in blueprint inside the plugin itself, feel free to look into e.g. LeapEchoHands_AnimBlueprint.uasset to see examples of how it is done. For a reference on how the whole setup works see

Have you had a chance to look through GitHub - getnamo/leap-ue4: Leap Motion plugin for Unreal Engine 4 and the main documentation in general?

Hey Getnamo,

Yeah, everything works, it’s just the grabbing with the floating hands I can’t seem to figure out.
Basic-rigged character works fine, but when I try to apply the grabbing to the floating hands it stops working when using the does implement interface.
Is it because there is no real mesh inside of the floating hands but a child actor?

So was just wondering how Catonice did his fix to get the grabbing working in the floating hands.

Thanks for the work on the plugin, really impressive to get your hands in VR.

I believe you’re right, the floating hands are built to support multiple types so the actual mesh will be in one of the child blueprints, open the floating hands character blueprint to confirm. You can also just place the floating hands actor into any blueprint of your choice and it should all just work out of the box.

e.g. the Plugins/LeapMotion/Content/Blueprints/Rigging/FloatingHands/LeapRiggedEchoHandsActor.uasset

@getnamo i tried adding LeapController.h to my character class and its giving me this error: ‘Leap’: is not a class or namespace name. Do you know whats wrong with it?? Thanks