Download

[Plugin] Leap Motion - Event Driven

Hi getnamo. There is a problem with overlap events. When I attach a mesh to hand socket (echo hands), overlap event triggers on and off constantly (every frame?). Everything is ok when this mesh is not attached to the socket (overlap events are fired only once). Any ideas on how to fix it? Thanks.

Everytime I try and enable to leap motion plugin with 4.11.0 in a new project I get a crash when I restart.

now is apply only hand direction in world.
I want to get direction of swipe gesture by hmd direction.
How do i get that? sorry about that poor english^^leap_gesture_bp.JPG

now is apply only hand direction in world.
I want to get direction of swipe gesture by hmd direction.
How do i get that? sorry about that poor english^^leap_gesture_bp.JPG

After using floating image hands i’ve got this error and crash:

its fresh install of ue 4.11 with official leapmotion plugin test level .

Has anyone else encountered the following message with the 4.11 update?

I got this both when I tried to update an existing project from 4.10.4 to 4.11 as well as on a new blank project with the default pawn being a subclass of LeapFloatingHandsCharacter.

Any ideas what this could be?

Super quick question. Is is possible to use a custom avatar with the plugin? With the ability to track only the left or right hand via blueprints? I’ve gone over the “Add Convenience Leap Hands to Custom Character” on the github page and can’t seem to get the plugin to pick up my avatar. This is on 4.11.2 source build too.

Hey guys,

Just letting you know I’ve released a Blueprints Getting Started Guide for working LeapMotion in Unreal. I also show how to display the passthrough cam on objects within the world.

If you’re interested, check it out here:

https://youtube.com/watch?v=fmtBQzD7ZFE

Hello All, I’m rather new to BP and Leap in general, but I’m picking it up rather quickly.

I’m wondering if someone can point me to any information on how I might ‘customize’ a hand with custom geo!? I’m still trying to grasp how it’s all connected. I’m wanting to create my own mesh and skin it to the skeleton that is driven by the Leap system.

Thanks for any help in advance.
Cheers.

<edit>Assume I already can generate my mesh in my own 3d package, I’m speaking BP/Leap specifics… thanks</edit>

Last Post Answered:: Well, that turned out to be much easier than I had anticipated. I was able to setup some sockets on the joints, and apply custom meshes to it, no problem. – So that’s good.

My next question is: How can I mirror the Y input of the Leap, so that if I’m looking AT the HMD instead of from it, I can create a ‘mirror’ effect. As it is setup now, if I move the camera and look back at the HMD, the Leap controller’s hands move correctly, yet opposite of what you’d want if you were looking in a mirror. At first I thought I could simply negate the screenspace Y, but that seems to be rather complicated in Unreal for some reason. So now I’m looking to see if I can inverse the Y input from the leap!? I’ve poked around in the LeapAnimBodyConnector, but am still trying to wrap my head around it all.

Any advice on how best to create this effect, would be greatly appreciated.

Again, Last Post Answered. :smiley: https://forums.unrealengine.com/showthread.php?109302-How-can-I-Flip-my-Camera-s-display-in-the-Y-axis

Now, I’m moving onto how to customize a Leap Hand. I exported out the echo_lo_R hand as an fbx, and brought it into my 3d package. ( Maya ). Then I parented some geo to various bones, ( I’m making a muppet ), and tried to re-import it into Unreal and hook it all back up.
Everything SEEMS to work, including the visibility bool, but it doesn’t pick up the animation from the controller. Basically it appears, and just sits there.

So I have some work on how to tweak/customize a hand… I’ll keep you posted.

Cheers.

Is there a way to detect if the leap motion controller is connected (via Blueprints)? Currently I’m using the LeapFloatingHandsCharacter and I want to disable their collision if the controller is not connected. I want to use them for VR, as an addition option to the vive motion controlelrs. My pawn has no collision, but the hands still have, even when no hardware is connected.

LeapM Can’t find file for asset /Script/LeapMotion 4.11 mac (I’ve posted this on the ueanswershub aswell)

Hi,

I’ve just started playing around with Unreal + clean installed Unreal 4.11 and followed the steps to get the Leap integrated with Unreal. However keep getting messages that it can’t find the file for asset /Scripts/LeapMotion // all the blueprints used in the Leap Motion plugin have unresolved compiler issues. Have tried to google a bit on the subject but can’t find what I’m looking for (my googling skills are probably terrible but I’ve spent too long searching).

In the tutorial they use VR mode to preview the Leap Motion hands and because I’m using a mac could this be the issue? I’m pretty sure you can still use Leap in Unreal even though it’s not in VR.

If you could post a link to the answer or offer some help - that would amazing.

Thanks for your time,

There is an “Is Connected” boolean from the Leap Library that you can simply branch with.

cd3b3490141f382bd47fe617cead3ccb1f4eaa8c.jpeg

Thanks you very much, that was exactly what I was looking for. Do you happen to know if there is an event I can use to enable collision again, when the controller gets plugged in at run-time? Checking every frame doesn’t seem like a good choice.

I’m using Leap Motion without VR, so it definitely works without VR.

What “steps to get Leap integrated with Unreal” did you follow? All you need to do in 4.11 is enable the plugin in the editor. Make sure you didn’t download an old version of the plugin and installed it manually. If that’s not the issue, I don’t know. I’m on win7, could be a mac issue or something else entirely.

Last supported Mac build is 4.10 atm grab it here: GitHub - getnamo/leap-ue4: Leap Motion plugin for Unreal Engine 4. The Orion runtime that was included in 4.11 was windows only, but that may change as we move forward, I’m due for a 4.12 update (outside engine for now, not fully stable). I do want to have Mac supported in engine, but in meantime try out the older builds.

Just wanted to say these are great, want them linked in the opening thread message?

thank you so much I’ll give it a go! :slight_smile:

Hey, thanks for the quick reply! I had a go at downloading and running leap 4.10 with unreal 4.10 but don’t see any rigged hands in the scene. I created a new gameobject blueprint and have tried all the different leap motion actors with VRplayer and with player controller & changed the gamemode override to the leap game mode but unreal doesn’t seem to be picking anything up. I’ve tried you’re jenga example with 4.7 and that works perfectly! am I missing something? Thank you

hey that worked! I still had a camera / character in the scene so it wasn’t getting picked up. Silly mistake. Thanks so much for your help, you’ve been brill! :slight_smile: