[Plugin] GEngine is NULL, how to get the GEngine object?

I got an identifier "GEngine" is undefined when I’m developing a plugin which requires to get the WorldContext.
The plugin runs on a different thread. It starts a UDP Receiver from this module.
The connection works correctly, however when I call GEngine variable (from the UDP handler), this value return NULL.

I have tried to search all of the issues regarding this GEngine being undefined.
Thus, I have ensured that #include "Engine.h" is already in both the CPP file and the Header File at which GEngine is being called. But the error is still occur during the runtime.

What else am I missing to retrieve the GEngine?

After spending time debugging from the Visual Studio through the intermediate window. It seems that I couldn’t access GEngine from VS intermediate window

I know this right after I tried to assign the GEngine into a variable, and apparently GEngine is there all the time.

UEngine* engine = GEngine;

and the intermediate window seems to display the engine members correctly.