Plugin Apex CLoth 3dsmax the Mesh Disapear

yeah sure, that would be great.

Ok, lets see if I can solve your problem ^^

btw, you are from germany? :slight_smile:

ja so siehts aus, aber ich dachte mir wir schreiben hier mal lieber english damit andere das nachvollziehen können. :wink:

I did sent you the model, did you get it?

Nice, dann sag mal “Hallo” zu den anderen deutschen Entwicklern: German Developers - Europe - Unreal Engine Forums :wink:

Yep, I got it and I’m currently trying out some stuff, but I cant find anything that could be wrong -> but I try to recreate the problem in blender with one of my chars

-make sure that the rigg has the same size in pose and animation mode
-are your vertex groups correct? -> so are all vertices from the cloth part assigned to the bone
-connect it to another bone and try it again

wow it helped thank you so much.
I bound it to another bone and now it works.
I dont know why but it works.
Thanks you man.
If I ever can be of assistance to you just shout.
Im new to UE but maybe i know some stuff about C4D or ZBrush you dont.

Nice to hear that it works now and thank you for your offer :slight_smile: When you have more questions, just ask them in the forum, I will always be here to answer them :wink:

Heyya its me again, of course it didnt went the way i wanted ^^
Im really trying to figure this apex stuff out, but im banging my head against the wall.
And you seem to be the only person that knows what this is all about.
So now im struggling with the collision of course.
It really just doesnt behave in any way I understand. I worked a lot with physics simulation but this apex stugg just seems broken (or me ;))
If I understood it right, then you cant make the cloth collide with the mesh itself in UE4, you have to collide it with the bones + collision distance (Which would basically be a real thick set of bones)
I think this is not a good way to do this, because the mesh does often not look like the Bone structure.
But anyways i tried it, with no success.

i added a kinematic rig to my cloth object, set the physical shape to bones and inflation to 1.
I then added the corresponding bones to the rig.
I played around with various values for inflation and collision distance and other variables.
But the cloth always pokes through the mesh or gets pushed to far out, sometimes it isnt even symmetrical.
The cloth get pushed to one side of the model. Its really odd.
Did you encounter something like this, fighter?

I also had problems with the collision some months ago :slight_smile: -> have you already increased the contact thickness?

Or just send me the mesh and I will try it out :wink:

Yeah with collision distance i meant contact thickness.
Im uploading my mesh, should be there in 2 minutes. thanks again for wasting your time on me :wink:

I received your mail. Lets see if I can solve your problem :slight_smile:

Could you probably post a video of how it looks like in your case? -> because in my case it nearly works as it should ^^

thats the video see for yourself.

Don’t paint with a high max distance onto parts, which nearly wont move (the parts where you have the problems dont move so much in real life) -> e.g use a distance from 10 for the part over the hips and 0 for critical places where the mesh will go through the cloth

example:

3b7ce7ff92278752d289790b4c6270b72f800d95.jpeg

Thanks again, fighter. I was used to to do it otherwise from other cloth animators.
Now I applied the max distances exactly like in your picture.
Now when simulated it looks like this.


I used a contact distance of 55 and as you can see the cloth gets bloated up to much and it pokes through the mesh so decreasing it the contact distance makes it shift through the mesh even more and increasing it bloats it up even more.

Could you probably resend me a e-mail so that I can send you a .max file? I have added a cloth effect to the mesh which shows you how I have done it -> I just have set up the upper part :wink: (but of course you will have to do some small improvements to get a perfect cloth)