Plugin add framework fails. dyld: Library not loaded.

Hi, everyone. I wan to add some frameworks to my plugin, but I have some problem.

I use Xcode to lunch project to iPhone or iPad, hit breakpoint and debug log show this error when app start .

dyld: Library not loaded: @rpath/AWSCore.framework/AWSCore
  Referenced from: /var/containers/Bundle/Application/F18C4389-A9A2-446B-AC61-B7121C2C81DD/PluginDevZone.app/PluginDevZone
  Reason: image not found
(lldb) 

this is build.cs.

           if (Target.Platform == UnrealTargetPlatform.IOS)
            {
                PublicAdditionalFrameworks.Add(
                    new UEBuildFramework(
                        "AWSCore",
                        "ThirdParty/AWSCore.embeddedframework.zip")
                );

                PublicFrameworks.AddRange(
                    new string[]
                    {
                        "CoreGraphics",
                        "Foundation",
                        "UIKit"
                    }
                );
            }

framework link here.

Anyone know how to fix it?
Tell me, please.

Hi ALangHung,

Sorry for the delayed response. I just wanted to check and see if you were able to get this working, or if you still need some help.

Tim

Help me please. I still get in troubleā€¦

Sorry, I lost track of this post. If you are still having trouble with this, have you tried using "../../ThirdParty/AWSCore.embeddedframework.zip" when adding the path to the framework?

Also, is there a reason why you seem to only be using part of the AWS SDK? Have you tried using the GameLift plugin that Amazon made available for UE4?

Tim