Please wait... help

No need to spam the board with the same question. To be honest, you’ll probably get a better response for something like this through the forums. More developers and programmers visit the forums than they do Answerhub.

I tried uninstalling 3 times, restarting computer, unblocking the install of the launcher… nothing! It just says " Please wait, when trying to install URE 4.8. I also included the launcher log file in a zip folder here. Not sure what to do, and I am computer savy link text

I didn’t mean to. It kept saying error when I posted. Sorry

It says Please Wait… Have you tried waiting? If so, how long? its not the quickest process even on decent machines.

Hi R1nzler,

This is an issue that we have been trying to resolve.

I would first try disabling your firewall if you have one active.

If that doesn’t work, some users have had luck doing a full uninstall/reinstall of the Launcher.

  • Uninstall the engine version

  • Then go to this folder (your file path may differ slightly): C:\Program Files\Unreal Engine\Launcher\VaultCache

  • If there is a folder/file contained inside called ‘UE_4.8’, delete it

  • Now re-install the Launcher

My firewall isn’t the issue or my anti-virus S I disabled them alread and re-downloaded 3 times BUT I will try and delete the URE 4.8 folder in about half an hour and post my results.

Ok so I just checked and NO folder for URE 4.8 in the Epic installation destination at all … :/. It didn’t even try and download, it seems like the connection isn’t being established at all. Is there anything else I need? I downloaded the Epic Launcher after making an account. That’s all I did. Computer is up to date, nothing wrong with it and is a high end PC

You can try the standard troubleshooting suggestions to see if anything works.

If nothing does, make sure to also include your entire Dxdiag (system specs).

We are currently investigating several similar issues but we haven’t found an official workaround that fixes the issue for everyone yet.

Hi R1nzler,

Give the workaround posted here a try. Let us know how it goes.



i really dont know alot about the engien and all this things, i just want to pkay the game (unreal alpha)
i downloaded the launcher; and after installing its just stay on the “please wait” window with a marking sign and dont log in.
i try to uninstall and reinstall.
to clear registrys.
change things in my port (wich i dont realy know how to do so maybe its the problem)
run as admin
try the guides in the site
read any question thet someone wrote about it.

and nothing helped.

please help me

Hi SagiDarkStar,

I see that you already have a new topic posted. I’m going to close this thread the respond to you there.