Please someone help I am not able to download any version of UE 4 its getting stuck at some point

Hello all,

     I was using UE 4.10.1 and then at 21st January I decided to update engine to 4.10.2 but during update when 634 MB were left to download it got STUCK for whole day then I thought I must reinstall the engine so I did uninstall engine and put it for reinstall but then again it got stuck at 40% for 2 days later I removed epic launcher and newly installed it + used CCleaner and registry cleaner as well but nothing worked ..........so I decided to leave it like that for few days to see if it gets further but NO it didn't move at all in the....LOG file of the launcher ..I saw the ".PNG error" ....after that I decided to format my C Drive and newly installed the windows 7 64bit but again the same problem........then I decided to download 4.9.2 but still the same it also got stuck at 36% for whole day not moving at all now doing all these download process from 21st Jan man I don't know how to get this done ...still trying but guys if anyone do have the solution please let me know......(I really don't wanna use GITHUB to download files the process is difficult + then I have to download VStudio 2015). PLEASE HELP

Thank you

Hi delvegamer,

This would be best served on the answerhub in the Installation and Setup section. Please make a post there so we can assist you more in depth.

I have already upload this question on the answerHUB + did upload my log file and Dxdiag file also but noone replied yet

Here is the link: https://answers.unrealengine.com/questions/364958/ue-4102-downloading-getting-stuck-at-40-waited-for.html

Thank you for the update. I see that Brian Lee is already working with you on the answerhub post you have linked. Please give up to 4 days for us to test and reply. If, after 4 days from the most recent post you have not heard back from us, please feel free to bump the thread once.