Download

Please make "favorite" Blueprint actions still show up in the context menu

I probably spent 20 minutes looking for the “Event Begin Play” and “Spawn Actor from Class” actions in the blueprint editor, trying various variables/contexts/searches, and not finding them.
Turns out that they are in the “favorites” window and thus, apparently, don’t show up in the context menu, which was the only place I was looking.
I would expect that all the things should show up in the context menu, even if some have been added by someone (like, Epic defaults) to the favorites panel.

This is not the behavior I see, in any of the versions I’ve used. Perhaps you’ve run into a bug?

Here’s the picture that shows that “Spawn Actor from Class” doesn’t show up in the (unfiltered) menu:

And here’s the picture that shows that it works fine if I use it from the Favorites panel:

And here’s the set of steps I took before then:

Create a blueprint:

Create a function:

Try to find the spawn function using the auto-filtered menu:

The fact that it doesn’t show up in the unfiltered menu is what annoys me the most – isn’t everything supposed to be there?

I don’t know since which version it has been added, but in UE 4.7.3 there is an option in Editor Preferences > Blueprint Editor called Context Menu: Show Favorites Section.
If you check it, all your favorites will be displayed at the top of the action list if Context Sensitive is checked.

In addition, you can check Flatten Favorites Menu to ensure a non-hierarchical access to the various actions. If you begin typing the name of the action, you will see it both on the top of the list and inside the list hierarchy, where it should normally be.

Now if you don’t check Context Sensitive it will not be displayed and you have to use the Palette Window. I don’t really see why but at least you will know what is wrong if it doesn’t show up.

The thread is old but I hope it can help other developers searching for this issue and falling here!