Please let us choose whether to center viewport preview horizontally, vertically or both

If you customize the viewport position, it will keep moving by that amount at every preview. I’m not sure if this is a bug or not but it’s annoying. Centering to screen literally centers it both vertically and horizontally. So say you’re previewing using an iphone resolution, half of the screen will be cut off. So it has to be dragged at every play test. Maybe I’m doing something wrong but the two options given aren’t very obvious on what to do to keep it within the bounds of the screen.

Hi hedgie17, with which version of UE4 are you seeing this issue? Is it the Mobile PIE or the new editor window PIE? I thought I fixed this previously. Cheers,

I’m using UE 4.25.3 and previewing from a widget/game instance/controller.

Using only the default playback, not mobile preview. Please let me know if you need more info. Thank you!

I’m not able to repro it with my setup and UE4.26. Out of curiosity, what is your monitor setup like? Single screen, double? Resolutions?

Single screen,
150% DPI (The MS Windows scale and layout setting in display settings)

Enable high DPI support in unreal is also checked.