Download

Please hide the Text Render billboard icon

I just noticed that the Text Render actor has a new billboard icon (a square with a capital T and a lower case t in it) that is shown in the viewport. This wasn’t there in UE4.

The problem is, this new billboard now covers the text you are trying to read. I know the billboard is hidden in game, but that is not the issue. The problem is when you are trying to label things in the editor for yourself. You now have this billboards covering half your text. It is also an issue when loading assets from the marketplace as often the asset creator will use Text Render actors to place instructions and such in the sample level. Now these billboards cover the instructions.

Please Epic, hide the billboard icon in the editor.

If you look in the Details panel for your Text Render actor, there is the “Editor Billboard Scale” property. Setting that to 0 will make the billboard invisible.

1 Like

I did not know that. I tried looking for something like that. Must of just missed it. How annoying though that you have to do that on every text renderer you drag into the scene. Why that is not 0 by default is beyond me???

You could make a subclass of the text rendering actor and set that value to 0… that could be a pain to use though. Or you could modify the engine to make it zero by default.