Please help with a tessellation issue

I did a variety of tests when it came to tessellation using PN Triangles with 2 materials on one model. There are no issues if I’m using a static mesh. As soon as I bring in a skinned mesh, one of the materials extends the tessellation past the UV island.

The example below shows a static mesh on the left, with one tessellated material applied to the problem UV island. That tessellates fine. If I apply the same material to the lower half they both tessellate correctly.

The right is a skinned mesh. As you can see the tessellation extends beyond where it should. I thought it could be a skinning issue, so I made sure the area where the second material is applied had a weight of 100% to the head bone. So that doesn’t seem to be the problem.

If I switch from PN Triangles to Flat Tessellation, both halves tessellate correctly. Do you have any thoughts as to what else I can try, or is this a bug that needs to be looked at? I’d like to use one continuous mesh if possible.

Thanks!

If I take the same model; one with skinning applied and the other without, export them out with FBX into U4, the non-skinned mesh works fine and the skinned one has the “spikes”.

I’m using one material with two instances of it. Both instances have the same parameters, but just a diffuse color change. If I assign both those instanced materials to the polygons that have the 2nd material applied in Maya, the “spikes” go in a different direction.

Could it be that the way I’m creating my second material in Maya is the problem? What I do is import my mesh which already has the default “Lambert1” material applied, select the polygons that I would like to assign a new material to, right-click and choose “Assign a New Material…” Then I export that as an FBX. Within the FBX settings I only have “Smoothing Groups” and “Reference Assets Content” selected under the Geometry dropdown.

Maybe it could be an FBX exporting problem too? Anything else I should check off?

Here is the same mesh with 2 different instanced materials applied to it; the only change in the material is the diffuse color. As you can see, each material results in a different “spiking” problem. Even though the materials are identical with the exception of the diffuse color.

Using Flat Tessellation works fine, both with my character skinned and not skinned. PN Trinagles works only if my mesh isn’t skinned. As soon as it is, I get the spiking problem.

Here is a new mesh, no UVs, and I’m still having the same problem. The Left has one material applied, and the right has two areas in which has unique materials applied. In Maya I select the polygons and in the drop-downs Marking Menu I select ‘Assign New Material’ to those polygons.

Here is my material:

I also tried skinned my original character in 3DS Max 2015, and I get the same results with “Spiking”.

Here is my testing mesh that has the issue.

Here is another test mesh, this time a basic model with a custom skeleton created in Maya with the join tools. I also included a non-rigged mesh. If you import them both into U4 and assign a tessellated material into the channels, the non-rigged mesh tessellates correctly and the rigged one has the spiking issues.

Hey AdamZ -

Your newly uploaded models are not showing an issue beyond the expected issue of vertices not lining up when you tessellate only one half of an element, so definitely no spiking in either version though. Your original model has some weighting issues which are probably the case of your stretching. Both the Left and Right thigh Twist have weights in the head which is incorrect and would cause issues. Here is a screenshot:

f0da0598fb385fa395c23b86707e8794a8b970b7.jpeg

Are you sure you’re setting your tessellation to PN triangles? Here is a screenshot. You can see how the neck area where the second material is applied is “spiking” down. I just did a quick skinning test to show you the problem, that’s not my final model.

Here is a screenshot of my properly weighted model

If you download this mesh, it’s a basic model with a custom skeleton created in Maya with the join tools. I also included a non-rigged mesh. If you import them both into U4 and assign a PN Triangle tessellated material into the channels, the non-rigged mesh tessellates correctly and the rigged one has the spiking issues. I checked the skinning of the model and it’s clean.

Here is a screenshot of the Softimage Man. One thing I noticed that if I drag both meshes into U4 at the same time, the rigged mesh doesn’t have “Import as skeletal” selected.

Did the Softimage Men help with trying to sort out the problem?

I don`t think he can as he, like myself, had no issues with the model (I did those from post #8).
The problem is hiding somewhere else.

I created a new mesh in 3DS Max, and exported it both with and without skinning. You can click here to down my FBX’s.

Screenshot 1 shows both FBX’s. The one on the right shows the un-skinned mesh with two tessellated material applied. That renders fine. The one on the left which is selected is the skinned mesh without any materials applied, which you can see in the material attributes in the lower right.

As soon as I apply one tessellated material to that mesh, it condenses the meshes material attributes into one, and I get the “spike” effect. Screenshot 2.

Screenshot 3 shows my tessellated material.

Screenshot 4 shows my 3DS Max material setup.

Screenshot 5 shows my UV’s.

Wherever the UV island gets separated, that’s where the “spikes” appear. I submitted a bug report here with little avail.

Anyone else have any suggestions, or maybe Epic can chime in again?

Thanks.

I think this might be related to the bug I have reported some time ago, look here Crack Free tessellation on skeletal meshes breaks on different material groups - Rendering - Unreal Engine Forums

I hope they get it resolved soon.