Download

Please Help - Quest 2 on UE 4.26.2 - Tried everything, followed all documentation

Hi,

I’ve been at this for over a week. I initially tried by following videos and some bits, but soon realised left quite a bit off or my install of Oculus Desktop software corrupt etc. Got to point where could connect and depending on what installed/uninstalled, I could atleast for most part see the Quest 2 appear on launch list and atleast attempt to build to varying degrees of progress.

I had a few old UE version and old android versions, and I tried to use NVPACK and stuff. I think it was all causing too much confusion. I uninstalled everything, clearing out every last trace of NVPACK, registry and environment variables. And fully wiped AndroidStudio as ended up with few versions of that, got rid of all settings files and any trace of any SDK.

Started again, followed documentation to the letter.
First :

Then :
https://developer.oculus.com/documentation/unreal/unreal-gsg-quest-quickstart/

My problem is, now the Quest 2 isn’t appearing at all. (Definitely hitting ok on the approve messages in the headset)

Yet, It’s just not appearing at all.
Yet

I think the issue from reading, and noticing would sometimes stop it appearing on launch menu in previous attempts by setting these paths incorrectly. Is within the Android SDK menu, but it is all set.

I think my environmentals set correctly too, they’re all the default that got put in there when installed.

UE4 and Oculus both see the device


QuestActive

The NDK installed correctly, and isn’t showing any warnings about cfg file.

SDKs installed



Addins ticked.

I’m at a complete loss. It’s driving me bonkers. It’s super frustrating I’m further back then was, after actually following the instructions better - saw lots of stuff when redoing it that had missed or glossed over.

So, I’m not sure what the problem is, but my preferred way of troubleshooting/sanity check Quest not showing up in UE:

open a command prompt (windows key + cmd)

type adb

this should spit out a bunch of adb commands.

If it does not/If the command is not recognized - continue to troubleshoot your environment variables.

Then, once adb is working, you can type ‘adb devices’ and it will list your connected quest (and ad this point UE will see it too)

Hope that helps!