Download

Please help me figure out why I get this weird stuttering in a network fps game?

Hi.

I started a mp game with my friends, and I took the third person blueprint template and made it into an FPS game.
I made a simple logic for my friends to join my lobby trough ip connect.
3 players connected, but as soon as we played all the players noticed a short of double frame stuttering on our characters.

Now, I made a topic on this on facebook group “ue4 developers”, I have tried all the suggestions coming in to fix this, and at this point I am at a loss. I just cant figure out what is causing this.
I even made a completely fresh project with the first person template, and I still have the exact same issue in that as well.
I decided to record the issue, to see if anybody could clarify (as it is impossible to get a good screenshot of it)

At 11 seconds the issue shows particulary well, you can clearly see that there are 2 frames of the character in different positions.

https://www.youtube.com/watch?v=IvIPldb8NvI&feature=youtu.be

List of things I have already tried :
-Turn off ambient occlution
-Change the AA, I have tried all 3.
-Turn off motion blur.
-Increase the fps
-Turn off Vsync
-Started fresh project.

I would also like to point out that I have a good computer.
Gtx970, 4790k, 32 gig ram.
I am running windows 10.
Unreal Engine 11.2

Extra note :
One of my friends, hangout in a browser window for a while, and claims that after he clicked back to the game, everything went supersmooth…
But I cant seem to reproduce this. He claims he didnt change anything trough console commands.

Clicking outside of the game window will cause stuttering till you return.

But if your getting this stutter in game it looks like your replication of location is the cause?

Is it worst when you run backwards? Check if you have orient direction to movement.
I had same stuff, it is almost invisible in singleplayer, but in multiplayer you can see this.
That stuttering was caused by 2 concurrent updates: one was my blueprint orienting player pawn to camera direction, second was character movement trying to orient pawn to its movement direction.

Ps. And yes even Epics templates suffer from this, so check that orient to movement direction property.

Thanks for the tip Nawrot, I will check it out and see if this fixes the issue… I will write here if it fixes the issue. :slight_smile: