Download

Please, fix the horrible mouse input lag with Unreal Engine 4 for shooter games

Over the years, graphics have become more and more heavy to render and this ‘‘mouse input lag’’ issues became a big problem with many games and game engines. That is precisely why Quake 3 Arena, after 20 years, still offers the best ‘‘mouse feel’’ that we can find out there. And from memory, I think DOOM 2016 running with the Vulkan API is one of the only great looking shooter game that doesn’t seem to have much mouse input lag.

The mouse input lag issues have been present in games developed with Unreal Engine 4, but also with Unreal Engine 3. Unreal Tournament 2K4 also had this issue, except that at least it had a decent option to reduce input lag. FPS players have been complaining about this issue in games developed with Unreal Technologies since at least 2007 (Unreal Tournament 3). Many of us were hoping that this mouse input lag issue would finally be fixed in Unreal Engine 4, however the issue is still present. Shooter games are some of the most popular genres, it would make a lot of sense to spend a considerable of time, money and effort to make sure those games feel right when we play them.

As we can see here the following thread of Unreal Tournament Pre-Alpha, it shows that the UT dev team recognized the existence of this problem, but didn’t seem to be sure of what was causing the issue. And didn’t yet have the tech to fix it either. I heard that the Vulkan API could be available for PC later this year. not only I hope it’s true, but I also hope that it could help fix this issue.

https://www.epicgames.com/unrealtour…-investigation

Please Epic Games, could we fix this mouse input lag issue once and for all?
For all shooter game developers & players out there, we would greatly appreciate it.

Thank you in advance,

I’ve gotta be honest, I’m usually hyper-sensitive to this kind of stuff but I’m not seeing what you’re talking about. I just booted up Counter Strike: Source and a brand new UE4 FPS template project at the same time and I can’t feel any noticeable difference between the two.

I’m sure you’ve already looked into this but have you turned off mouse smoothing and FOV-scaling? I always uncheck these in new projects as I think it gives the best mouse feel. After those two tweaks and getting my sensitivity right I can’t tell the difference between my project and Counter Strike, which I would consider the gold standard. Anyways, maybe I’m a bad test case because I use a 144hz monitor but I doubt a 60hz monitor would be much worse.

Use hardware mouse if you need precise input. Any project that uses Slate/UMG cursor will have some mouse lag.

Its easy to test this by enabling both at once and you can see the UMG widget cursor lags behind a couple frames.

The mouse input only feels ‘‘oky’’ if I run the game with Forward Shading and 150+ fps.
That’s fine with Graybox map, but with my current herdware, any meshedmap in UE4 runs at 60-100 fps. Very unstable.
Some friends of mine upgraded their PC and can now run UE4 games at 200+ fps, so I’ll upgrade my PC as well in the next few weeks.
And by the time I release my game, people will probably have time to upgrade their PCs as well and hopefully the mouse input will not feel like garbage for them as it did for me in all past UE4 games.

Unless you have a monitor that’s higher than 60hz there’s no reason to try and get a higher framerate and you’ll get better performance if you force a frame cap at 60fps

Some of us who are into competitive multiplayer FPS games have been playing games at 150+ fps for over a decade now. The higher the frame rate, the better the mouse input gets. Even if your gaming monitor was limited to 60hz, you could definitely see a difference in player performance from playing CS Source, Quake 3 Arena or UT at 120+ fps.

Personally, like many others, I play with a 144hz gaming monitor and tend to run my games at 150+ fps. UE4 games are best experienced at 200+ fps. And if you play fast pace FPS games like Unreal Tournament or LawBreakers, you really want 150 fps steady and and 144hz gaming monitor to see things clearly when moving the camera. At 60Hz, it’s just a big blur and I move my camera 80-90% of the time. It’s also the same reason why Temporal AA is bad, because that means 80-90% of the time, everything looks blurry, because you need to stand still for a while to get a sharp image with TAA.

I’m personally developing a competitive multiplayer FPS game and this mouse input issue is everything to me. It makes the game feel right or wrong. Aiming is more than 75% of the game experience.

And I want to clarify, it doesn’t mean we can’t aim in UE4 games.

Video
https://youtu.be/37bSflm_LIg

I’m just pointing out the fact that UE4 games currently all suffer from some mouse input latency. It’s almost like playing with Vsync all the time even if it’s set to Off. That’s how it feels like. As you can see in the two videos below, I can still aim. All I’m saying is the mouse feel feels horrible and i feel like I’m fighting my mouse all the time. in older FPS games, we didn’t have that, the mouse input was just clean, raw, super responsive. I don’t have to force myself to aim in Quake 3 or Counter-Strike Source. And considering that UE4 is the biggest commercial game engine out there, I think FPS devs would greatly benefit from having an option to make the mouse input as responsive as it should be even if that means that they need to compromise graphics. And Forward Shading didn’t solve this issue yet. As FPS game devs, we trust Epic to develop this awesome game engine for FPS games and it seems that Epic currently values graphics more than gameplay. It would be nice if we had an option to choose the opposite.

According to most feedback I’ve read about the mouse input lag in UE4 games, the mouse input in UE4 games feels ‘‘right’’ only when the game runs at 200+ fps (stat FPS indicates 3ms instead of 6ms or 11ms) . And then it’s somewhat similar to what we find in other games such as Quake 3 Arena, Counter-Strike Source, etc. The issue here is you need a very powerful PC to pull that off. We didn’t need 300 fps in those older games for the mouse input to feel responsive.

Apparently, someone might have found a fix. I still need to investigate this potential new method to get a more responsive First person camera.

Source:

Hello everyone,

I would like to announce that I have finally found the problem and how to fix the issue on all UE4 Games. This fix currently works for Unreal Tournament Pre-Alpha and this fix originally worked for Dead by Daylight. This is something that the software engineers at Epic Games should look into and investigate.

Since it was related to the following issue:
https://www.epicgames.com/unrealtour…-investigation

AMD FPS FIX (multicore and flipqueuesize)
Source: https://steamcommunity.com/app/38121…7615844128852/

For those who have issues with frame rate when capping it to let’s say 30 fps or 60 fps to get a steady frame rate, try turning ON motion blur. It helps.