Please fix texture blurring on objects when moving in rift mode

There is an issue where textures will blur in rift mode when moving around (such as the statue in the VR sample room) It creates the sensation that the eyes are converging causing eye strain.

This happens on all other demos/projects with rift mode enabled. It only appears to happen on items with materials added, not as noticeable on textureless objects. One user in forum post describes it as the texture “shimmering” This is discussed further in the VR forum section.

Link to forum post: Having trouble getting things looking right in Rift mode - XR Development - Unreal Engine Forums

Hey, I had the same issue. I had to delete all the post processing ( go to you Scene Outliner, search and delete). Its doesn’t help that the resolution is default to 1280 x 800. Please note that going forward there is going to be some blur added to VR.

Shake your hand in front of you up and down.Your brain puts a blur on it or look at fan spinning slowly: blur. Games can move that fast without blur. In VR “not on DK1” you will get extremely sick with out motion blur. It matches our brains adaptions.

Unfortunately Chris, that is not the solution. I have tried deleting all post processing effects but it still occurs. It is different than the blurring effect you mention. I can only recommend staring at the statue in rift mode as an example. But it does occur in all scenes even without the post processing and appears to be a “bug” in some ways.

If you want a clear image you have to go to your post processing volume and disable motion blur by enabling it and set the amount to 0 (weird but I guess there is default post processing values without post processing volume and the presence of a post processing volume overrides them), make sure that in ‘scene color’ fringe intensity, vignette intensity and grain jitter are disabled, or set to 0, if you want an even clearer image, in ‘misc’ set the AA method to ‘none’ (careful then, by doing so, some reflections will not be calculated, the issue is going to be fixed though)

Hope it helped ! Let me know !

Hi Haggler, as others have suggested elsewhere it does seem that the TemporalAA is causing the texture vibrate/ghosting while moving issue. I know you have said you have tried messing with the post processing but just bear with me and try this step-by-step (it worked for me):

  • make sure your scene has one and only one post process volume.
  • make sure Post Process Volume → Unbound is checked
  • make sure Misc → AA Method is checked and set to “FXAA” or “NONE” (to override the default TemporalAA)

See if that fixes it for you. The trade off is you get crappy AA compared to the amazing TemporalAA but the textures don’t vibrate when you move. I’m hopefull it is something that can be fixed such that we can have stereoscopic views with TemporalAA. I also suggest disabling the lens flare post process in VR as they are overly distracting as well.

Thank you! It appears it was indeed the temporal AA. The only difference was I “Launched” it this time instead of “play as standalone”. All is well. I hope they fix temporal AA with the rift soon.

Really suprised this wasn’t disabled by default in the VR demo as an example!