Please can we have a default VR project for Oculus Rift?

Im trying to recreate my house to scale but the player is too big compared to a real size room and i can’t even walk through doors, this is using all real measurements in cm, walking is also a bit quick.

I understand it’s still early days but i think more people will be interested in creating their own spaces for fun and ue4 should be good for the average person to pick up and start creating stuff. Eventually it would be nice to have a simple full body avatar to look at as well but for now having proper scale would be enough.

Until then how does someone new to ue4 go about getting player size and speed right?


By default, 1uu (Unreal Unit) is equal to 1cm.

You can change this in a maps “world settings”, which should then affect how a HMD behaves.

MaxWalkSpeed governs a characers speed while on the ground, in cm/s.

It is part of a characters movement component.

Size is set by a characters collision component.

By default, this is a capsule component with a Capsule Half Height of 96, making the players full height 192uu.

Player eye location can be controlled in a number of ways, though it is often based on a characters BaseEyeHeight.

You can find these settings and more under the Defaults tab of a characters Blueprint. They are also located under the each particular component, which you can find under the Components tab.

I’d suggest starting there, with the MaxWalkSpeed setting.

Hope it helps.


Please take a look at the Content Examples project and open the VR.umap to see an object with proper scaling for Oculus. That may point you in the right direction, though I would suggest following ’ instructions, since he writes tutorials for the Oculus.


Thanks, i appreciate the help but beyond mapping i have no idea what im doing when i open blueprints so pointing me in the general direction isn’t much good.

I was hoping for more of a step by step guide on what i need to change exactly so things look right, remember vr is coming and will only get more popular, not who might like to use ue4 is a dev who has time to learn the programming side of things, im trying to learn stuff but this is something i just want to fix so i can get back to mapping again.

No worries.
I went ahead and updated the wiki (yesterday) based on this and other information. I’ve included images to make finding the settings easier.

Thanks that’s exactly what i was looking for, now i just need to play with the settings until it feels right.

Hi ! I can’t find the VR.umap in my computer even if I installed Oculus runtime ( ) and if I Play the level in VR or Standalone game in both cases has a low focal length instead of the normal 35 mm! How can I fix it?
Thank you in advance!
alt text