Playing videos in UMG

I am trying to play a video as image in UMG, works fine in computer but not in my ipad air 2. I have tried every single video format that works with ios, but none works. Any suggestions?

IOS 9 , UE 4.9.1


What frame rates have you tried for the mp4 videos?


Which one should I use? And which is the best format to use? Thanks a lot in advance :smiley:

I’m not exactly sure what you would need in your case as I don’t own an iPad. But I developed for PS4, and I needed to have the video at 720p 24FPS for playback to work correctly. Have you tried that format?

I have just got a video and played it in the Ipad player and it works but in the game it doesn’t. What do you do in UE4 to play your videos in ps4?

Well I made sure the video was 24 FPS when I encoded it. Also, there was a minor bug I’m not 100% sure was fixed. So when you import a video, it creates the video asset and set the properties to the file location. It works on windows, but as soon as you cook the game project. Its unable to be linked during play, such as you are experiencing. What I had to do what go into the video asset, check to ensure the path was linked to the local*(I believe its a Movies folder)* copy of the video which Unreal makes when you import videos. You may have to copy the file into a local path of the game project yourself, then link it by searching for it on the computer.

I just imported as a test, and it make the path to the video file …/…/…/…/…/…/Projects/*/Videos/UnrealEngine/.mp4 – which is located on my computer. If I were to package this, it wouldn’t playback on any device.

Going on what Peter was saying… Have you made sure to move the video file to the Movies folder in your Unreal Engine Project…If it shows it located on the desktop or somewhere else then that folder it will not work on other devices.

In order to package correctly, local media files MUST be placed in the Content/Movies/ directory of your project.
Once you have placed your media in your projects Content/Movies/ folder, the warning icon will no longer be shown.

Ok I have tried to put in my videos inside the game folder, but somehow it still says “the current url points to a file that does not exist or is not located inside the /content/movies/directory”. Where should I put the videos? I cant find the movies folder they mention.

If you go on your PC and go to /MyDocuments/UnrealProjects/YOURPROJECTNAME/Content/Movies/ and place your video file in there…Once you do that you will see the … next to the video file name in the Unreal Engine editor. ** View image below **


What you need to do now is select the video file that you just put in the Movie directory above and the error will go away.

Thank you very much! My confusion is that there wasn’t a folder inside content called movies, but I created one there and it worked! Thanks a lot :smiley:

EDIT: The video directory works, but the video doesn’t work on my app on the ipad. REALLY strange, as the video works in the video player, not in the app though :confused:

Encode it as a quicktime movie.

I did try all possible video formats, but none worked. So quicktime is the best one? If you export yours in Premiere, which settings do you normally set?

Bump, wondering if anyone has any suggestion…

Bump! Looking to make use of this as well

3 months later… I’VE DONE IT!!!

So, the solution:

1-Follow the steps in this tutorial (- YouTube)

2-You must have your video in this format (I am using Ipad Air 2 and UE4 4.9.2): I used Premiere Pro for the conversion, in the export settings I chose H.264, then the dropdown below that I chose Apple Tv, Ipad 720p, then I changed to these settings: h.264, 1042x768,25fps, VBR 1 pass, No sound.

3-You must place your video in: YourProjectFolder-Content-Movies(Create a folder named movies if you dont have one)

4-In the media Player, you must go to the Source you must link it to the video you placed in the movies folder in step 3, otherwise it won’t work.

5-Considering you followed the tutorial in point 1, the last thing you have to do, if you want it to play in your UMG is to create a MEDIA TEXTURE VARIABLE, then you must assign it to the Media Texture of your video in the details panel.

6-Lastly, thanks to these thread (Media texture bugs,set loop and rewind fail on ios device - Asset Creation - Epic Developer Community Forums) The nodes you must write in the Blueprints are :

(IN UMG) - Construct-(get var created of media texture, then get media player,then drag of it the play node) and attach the construct to the Play node). And Voilá!!!

This method worked for me. Hope it helps someone else as well!

Also thanks to everyone that answered in this post. Wouldn’t have done it without you :smiley: