Playing Media Source Crashes Engine

Steps to reproduce:

  1. Put any file in Content/Movies
  2. Create a Media Source Asset
  3. Link the Sample video on it
  4. Create a Media player
  5. Play the sample video by double clicking on the media source inside the media player



Edit: Same thing happens in 4.13.1 as well. 4.12 plays it perfectly!

MP4 file. 3GP seems to work fine. Took the mp4 file from

What file format is the video you are putting into the movies folder. UE can be picky with the files

Hi Maxzerr,

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here: Unreal Engine Issues and Bug Tracker (UE-38834)

You can track the report’s status as the issue is reviewed by our development staff.


This was recently fixed in Dev-Sequencer (CL# 3168760).

As a temporary workaround, do not use videos with dimensions that are not multiple of 16 (i.e. 360 in your video is not a multiple of 16).

Hello there,

I have a similar problem too as I’m trying to upload .mp4 file but it can’t find the pathway to the file. Initially it worked with my 4.27 and I could upload the video and posted on plane and everything went well until I forced deleted the video to change to different video and then the nightmare started.

As I don’t use C++ for my project, please advise what should I do. My project is created by using 4.27 assets so I can’t go to a version below which is the media source still working. I tried to uninstall and reinstall 4.27 and still doesn’t work.