Playing an animation on top of one that finished snaps the object back (EventGraph)

Hi there,

Just to preface – I’m NOT using AnimBlueprints here, just basic animations fired in an object’s Event Graph.

From the attached graph, I’m testing to see if an object is in an array. If it is not, add it and play the ‘open’ animation. If it is in the array, delete it and play the close animation. I can get the animations to play, however not properly.

What happens is that the ‘open’ animation plays fine. However when I delete the object from the array, the animation to close doesn’t seem to play through. Although it does pop back to the ‘closed’ position so it is getting to the final frame ok.

Is there a step here I’m missing to make the ‘close’ play back as in the Animation asset? I’ve tried out “set animation” but I’m not sure what that does exactly and it didn’t give different results.

Thank you,

Could you do this repetitively? Once it plays close, and can you do them to play open again?

I’m wondering if some state of animation isn’t reset (such as position), so if you have them play open again, it will be broken too? Does SkeletalMeshComponent have AnimationSingleNode for AnimationMode since you said you’re not using any AnimBlueprint?



Hi Lina! :slight_smile:

Thanks for the reply.

To your question on the animation state reset – after the open animation plays for the first time, the close animation pops back, and subsequent open animations look like they play only the last 3 frames of it (so some parts of the anim are playing it seems). It’ll continue to open at the last 3 frames and pop back to closed until I restart PiE.

To your next question about the Animation Mode, I just did a quick test and it looks like on the first open animation (the one that plays fully), the AnimationMode is set to ‘Use Animation Blueprint’. (I’m not sure why, there’s not anim BP associated with the mesh.) However when the close animation and the open animation are played after that, it’s set to ‘Asset’ mode. I’m not sure why it’s changing…?

So for a fix I forced both the open and close to always play in ‘Use Animation Blueprint’ mode. And it worked! I attached an image of my updated graph. (the comment in there is for my own records :slight_smile:

Thank you!


Sorry for resurrecting this, but this did not work for me. I have a two part sliding door that does the exact thing that you describe, it will play the opening animation but when an event triggers it to play the close animation, it simply plays the last frame. Though it does “Close” it’s still not playing the actual animation.

Adding the “Set Animation Mode” for either option did not change anything.

I’m kind of lost in the swirling vortex of learning how animation state machines, anim blueprints, and others are triggered but so far I’m not confident I can use those with my current setup for controlling doors.

Did you ever find a more concise method for this?