Download

Playing a level start animation before controlling the character.

Hi, In my characters Blueprint I have an Event graph Begin Play node connected to a Montage Play referencing my montage animation. I had hoped that this would start the game with my intro anim, but I still go straight into my regular idle which is the base of my locomotion blend. Does anybody know what other steps I need to take in order for this to work? I am trying to reproduce the startup behaviour of a Paragon character.

Thank you

Try disabling input first, and then re-enable input after the sequence is finished.

the very fist step is to flag it for play and only play it once the character is not flying.
Most times characters spawn flying - and even more often, we make them fly on purpose so that you don’t get asinine errors/bugs where your characters sink below the floor or get stuck (a bug ARK never gave a crap about fixing…).

Then you can consider disabling input - or not. Paragon characters do not.

Paragon characters do this in the event graph of animations:

Hi, well I tried disabling input without any luck. It might be worth mentioning that I’m no programmer at this point and I thought flagging for play would be handled by the begin Play node which I expected to take precedence over EventBlueprintUpdateAnimation. My AnimBlueprint is set up just as your image showed MostHost, clearly, there is another step I am missing but trawling through the settings for a Paragon character, I can’t find where I am going wrong.

Maybe it is just the fact the character is flying. This is more of a coding thing though.
the answer is probably within the character blueprint begin play.

on begin play set a boolean to true.

In the animation montage create a “can move” notify towards the end.

In the anim BP call that notify and set the boolean to false.

In the anim blueprint, on control inputs, before operating the input branch out and plug in the boolean.
make sure inputs can only be pushed if the boolean is false.

That should do it without having to mess around with disable input and enable input - though you could very well use those nodes in a similar fashion…

Thank you, whilst I’m sure there are many ways to achieve the effect I wanted, using notifies sorted this.